Walk me through configuring Starcraft for my firewalls(s) pls ...

Hiya guys.

Well, I made an earlier post about configuring Starcraft for COMODO. But, now that I try to connect and after doing a -redo remember rules- thing (on v3.17), Starcraft still won’t connect to B.net.

Starcraft (latest patch which allows play without CD) crashes on Accessing Account area of connection. I have to force quit the application with Task Manager to revert back to stable state.

Now, I am guessing there is a major problem. Can you guys walk me through configuring COMODO for Starcraft (not just words and general things) ?

Also, I have a hardware firewall, and I have configured it accordingly:
Harden Your Westell 327 Firewall - Westell | DSLReports Forums → Used Inbound and Outbound medium settings
http://www.portforward.com/english/routers/port_triggering/Westell/Versalink327W/Starcraft.htm → self configured

Can anyone please help me configure my PC to play Starcraft ?? Thank you all very much !!

I’m pretty sure this should work.

Open up the comodo control window and click on the firewall tab. Then click on advanced on the side bar followed by the network security policy. From there click on add and then navigate to starcraft.exe or whatever it’s called (haven’t played that game in a couple of years), and if you feel confident enough, you can set the application to use predefined setting trusted (which allows all in/out requests), or set the in/out to allow the specific port that Bnet uses, something like Allow In/out UDP or TCP source ANY destination PORT may work (Personally I usually set games on trusted, since I’m too lazy to do the research).

Otherwise I suppose you could try to connect to Bnet and then minimize starcraft when you can and try to follow the trail of alerts.

Firewall>Advanced>Network security>add>navigate to starcraft>set a policy from there

Alternatively, you can launch starcraft and from network security, hit add then select running processes and locate the starcraft program from the active list.