Vuze and Comodo Firewall with router

I’ve been using Vuze and Comodo Firewall for years with a direct connection to a cable modem. A few days ago I had to move it to a connection with a router. Now inbound TCP and UDP connections fail in Vuze . Outbound TCP and UDP are fine. I originally used this guide by pandlouk to create a Predefined Policy/Ruleset. I know it’s not a port forwarding problem (I’m not using UPnP) because Vuze works if I disable the firewall. I’ve searched the forum but nothing seems to help. I rechecked the rules and even tried this adding a Global Rule like mentioned here. Anyone using P2P client or better yet Vuze that can help?

i use the official guide (bitorrent_vuze rules) and it works fine BUT i have had the same problems when i was on version 6.3 updated version 7 : i uninstalled old version cis (6.3) and installed new version (7) following the guide.
Both are on the site.

Which “official guide” is that? There are numerous guides on this site. The one I used by pandlouk is the same as the one on the Comodo Help site. I have version 7 of the firewall, which was a clean install not an upgrade from version 6. Which installation guide are you referring to? Is it this one from Chiron?
As I said before, Vuze was working fine when I was connected directly to the modem, but now with the router TCP and UDP incoming connections are not working. If I disable the firewall Vuze works fine, so I do not believe it is a problem with the router. I’ve created seperate rules for TCP and UDP In, changed the port settings to Any, added the global Rule I mentioned above but nothing works.

Hi enfa20,
What is the model of your router?
You tried to enable some internal option in your router that releases these connections?
The problem is only with Vuze?

The router is a TP-LINK WDR5300. I not sure what you are referring to about “internal option that release these connections”. I’ve rebooted the router a number of times while making changes. Vuze is the only program which I’ve noticed problems with. It works, but without incoming TCP and UDP connections I cannot receive remote connections (yellow smiley), and thus the swarm of peers is alot smaller than it should be.

I can not reproduce here right now, but see if it can be helpful to you:


Oh are you referring to the port forwarding rules from the router? I have two rules:
Service port: 62405 Internal Port 62405 IP Protocal TCP
Service port: 62405 Internal Port 62405 IP Protocal UDP
As I said above, if I disable Comodo Firewall Vuze works fine. Also I ran the NAT/Firewall Test in Vuze and it appears that it is only the TCP incoming that is being blocked.

And if you create a global rule for TCP / UDP protocol?

Yes I tried that already. When I was using pandloouk’s settings I used this guide by EricJH. I also tried this guide by Radaghast which includes a Global Rule for TCP/UDP In. The strange thing is UDP In works, but not TCP In.

Edit: I should mention that I’ve tried creating rules that have TCP/UDP combined and also seperate rules for each.

so it is the firewall ? which one ? maybe a conflict …

Which firewall? ??? Comodo Firewall v7.0.315459.4132.

Well I tried everything I could think of. I changed the port, used different ports for TCP and UDP, used at least 3 different P2P setup guides from these forums, did a clean install of Comodo Firewall, but nothing helped. I was going to try and install uTorrent or another bitorrent client but frankly I’m too tired and frustrated. It’s just so weird. Vuze worked fine with Comodo when the computer was connected directly to the modem. But when I connected it to the router (using LAN not WiFi) Vuze cannot accept incoming TCP connections, although UDP In works fine as well as UDP/TCP Out. I have disabled UPnP in Vuze and on the router, as well as set a static IP and forwarded the port(s). If I disable the firewall TCP In works.

yes _ this problem has been yet reported from users (whom myself & portuguese forum) … but it was about an update version 6 to version 7.
a conflict is when p.e you have two firewall or two anti-virus : it can happen because windows unblocks its component (trouble-shooting ?) ; i, with version 7, before the install ; i had to uncheck that and verify that all was ready.
are you in ipv6 ?
maybe your install of version 7 was not done correctly ?
it is that i meant, nothing else.

Which of these settings are you using?

Filter loopback traffic
Block Fragmented IP traffic
Do protocol Analysis
Enable anti-ARP spoofing

One or the other can interfere with the performance of downloads, and you set the firewall to hide ports?

Try testing with some setting off and see if you can re-establish the TCP connection.


As I said above, I did a clean install of version 7. I do not have more than one firewall or antivirus. I am not using IPv6, though what my ISP may be doing to the network in preperation for the transition to IPv6 I do not know. Yesterday I did a clean reinstall of v7 and I still have the same problem.

I have all those options disabled as well as “Filter IPv6 traffic”. One of the guides (I forget which) said to change “Stealth Ports” to “Alert Incoming Connections” and even had an alternate method that created a global rule. Still no help.

I happened to see this post regarding closed TCP ports. Could it be related?

it is not because we have had the same problem that the solution is the same ;D

May be related to this issue, try to report the difficulty that you are facing and provide the details about it. No doubt if it is a bug or some incompatibility will be fixed soon.