vpn settings

I have vpn access to my work… But since installing comodo, i cant get out - Im trying to work out what netowrk monitor rules i need to set to allow this

Ive tried making a zone… but things still are not working.

I can connect, But once connected i cant get to any of works webpages nor can i putty into my linux box

Once connected, these are my IP addresses:
Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    IP Address. . . . . . . . . . . . : 10.1.1.3
    Subnet Mask . . . . . . . . . . . : 255.0.0.0
    Default Gateway . . . . . . . . . : 10.1.1.1

Ethernet adapter Local Area Connection 2:

    Connection-specific DNS Suffix  . :
    IP Address. . . . . . . . . . . . : 10.250.250.84
    Subnet Mask . . . . . . . . . . . : 255.0.0.0
    Default Gateway . . . . . . . . . :

So the bottom one is the vpn adapter and the top is my normal local ip’s

Cisco vpn shows this:
Client details: 10.250.250.84
Server: 210.55.0.161 (this is also the ip address that i had to allow to let vnc access from work to home)

Route details - Secured Routs
192.168.0.0 - Subnet 255.255.0.0
172.16.1.0 - Subnet 255.255.255.0

I tried setting a zone for 210.55.0.161
Also tried setting a zone for the range of 192.168.0.0

But that still didnt help

I also must note… If i set comodo to allow all, Vpn still doesnt work, However it did before i installed comodo

Any help would be greatful!

The problem has to do with your DNS server and comodo not allowing the VPN DNS server to take precedence once you connect to the VPN. This is either a bug in Comodo or a setting that I don’t know about.

Here’s what happens WITHOUT Comodo:

  1. Connect to VPN
  2. DNS server sent through DHCP on the VPN is used as the primary DNS for all DNS queries.

Here’s what happens WITH Comodo:

  1. Connect to VPN
  2. DNS server sent through DHCP on the VPN is NOT used as the primary DNS. Rather, it continues to use the ISP DNS server.

Does anyone have any help with this? I’ve had to uninstall Comodo because it basically shuts down my VPN connection.

UPDATE:
Go to SECURITY → ADVANCED → APPLICATION BEHAVIOR ANALYSIS
and then uncheck the “Monitor DNS Queries” box

and then reboot.

This seemed to clear up the problem for me.

http://www.intelligent-isi.com

This worked for me also, YAY!!

Thanks Zimm

Hey guys, check the “remote access” tutorial in this thread:

https://forums.comodo.com/frequently_asked_questions_faq_for_comodo_firewall/tutorials_a_compiled_resource-t6167.0.html;msg45450#msg45450

The issue shouldn’t be about DNS queries, but about creating a Zone in CFP that defines the access point(s) for the VPN, and then using that Zone to define a Trusted Network. Doing this will create two Network Monitor rules to Allow All traffic between the two computers; one for Out, one for In.

LM