VNC connection problem using port 5900

I have UltraVNC installed on two computers and it works fine (attempted before and after Comodo installation). However, I want to block all non-necessary ports from the UVNC server.
Setup:
192.168.111.172 - contains VNC server and Comodo Firewall
192.168.111.2 - client computer with vnc client

Here is my rule:

Allow TCP In From IP 192.168.111.2 to IP 192.168.111.172 Where Source Port Is 5900 and Destination Port is 5900
Allow IP Out From IP 192.168.111.172 To IP 192.168.111.2 Where Protocol Is TCP

The above fails. However, if I allow Any port for Source, it works correctly… except I want to exclude all ports except what VNC uses.

Thanks for any responses. If any responder asks for logs… I tried finding them but was unsuccessful (looked in the program directory, and user directory\Application Data and Local Settings

Edit for system setup of server:
P4 2.66GHz
512MB RAM
plenty of HDD space
Realtek RTL8139 Family PCI Fast Ethernet NIC

  • at speed 100.0Mbps (full duplex)
    Windows Firewall = DISABLED
    Windows Firewall/Internet Connection Sharing (ICS) service = DISABLED
    Comodo Firewall only installed V. 3.5.57173.439