VMware Workstation 8.0 doesn't function properly with COMODO Firewall 5.8

The bug/issue

  1. What you did:
    Installed VMware Workstation 8.0.0 - build 471780. (While Installing, Defense+ was disabled). The installation seemed to be successful. Then I tried to power on a virtual machine, but VMware just didn’t work.

  2. What actually happened or you actually saw:
    After clicking “power on this virtual machine”, a message box appeared, which read:
    “Could not get vmx86 driver version: The handle is invalid.
    You have an incorrect version of driver “vmx86.sys”. Try reinstalling VMware Workstation.
    Failed to initialize monitor device.”
    followed by another message box reading:
    “Cannot find a valid peer process to connect to.”

  3. What you expected to happen or see:
    That I could power on those virtual machines successfully.

  4. How you tried to fix it & what happened:
    I uninstalled both Comodo and VMware, then re-installed VMware alone. Without Comodo, VMware worked well and the virtual machines can be powered on successfully. With joy and expedition, I installed comodo again afterwards, however, the same problem appeared once again.

  5. If its an application compatibility problem have you tried the application fixes here?:

  6. Details & exact version of any application (execpt CIS) involved with download link:
    VMware Workstation 8.0.0 - build 471780

  7. Whether you can make the problem happen again, and if so exact steps to make it happen:
    See 1.

  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used:
    Comodo Firewall Beta 5.8.206694.2075
    COMODO - Proactive Security

  2. a) Have you updated (without uninstall) from CIS 3 or 4: No.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

  3. a) Have you imported a config from a previous version of CIS: No.
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No.

  5. Defense+, Sandbox, Firewall & AV security levels: D+= Safe Mode , Sandbox= Enabled , Firewall = Safe Mode, AV = N/A

  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 SP1 64bit, UAC enabled, administrator

  7. Other security and utility software installed:

  8. Virtual machine used (Please do NOT use Virtual box): VMware Workstation 8.0.0 - build 471780

Same here. It works only when i run vmware as administrator. (Comodo Internet Security 5.5 )

Can one of you please verify if the new executables are ‘Trusted’ by CIS by going to Defense+ ‘View active processes’ and check the VMware services+apps running in the verdict column?

There were two service processes (vmware-authd.exe and vmware-hostd.exe) considered to be “Unknown” by Comodo. Then I manually added them to the trusted files list and restart the computer, yet vmware wouldn’t work.
BTW, running as administrator can surely fix that problem, though I don’t think it’s the best way.

vmware-tray.exe and vmware-unity-helper.exe are trusted.

Could you please report this in 5.8.206694.2075 BETA Bug Reports.

Thank you


Thanks :slight_smile:

Exclude vmware folder from shellcode injection (buffer overflow protection) under defence+.

Ah, it works. Thanks a lot.

Thanks for posting back :slight_smile:

Moved to Resolved.


I just wanted to note that this solution:

Exclude vmware folder from shellcode injection (buffer overflow protection) under defence+.

works even when Defense+ is completely disabled, which would be slightly counter-intuitive.

When you say completely disable did you tick the box and reboot, or did you use the slider to disable Defense+ ?


Just ran into the same problem. Defense+ was disabled but blocking vmware.
Excluded vmware folder from shellcode injection (buffer overflow protection) under defence+ fixed the issue.

There is a check and slider set to disable Defense+

Running Comodo 5.9.221665.2197

I’ve just noticed some strange thing happening since the CIS 5.10 installation.
Before i could run VMWare Player just fine. But with CIS installed i get these two errors (see attached images). I have to manually run it with “Run as administrator” command to make it work again (but didn’t have to do that before).

I do have “Enhanced protection mode” enabled in Defense+, everything else is basically set to default and shouldn’t affect anything.

After i removed CIS and installed avast! again, VMWare Player could be run without fiddling with the Run as Administrator command and there also wasn’t any errors when running directly without assigning any special rights to the VMWare.

I’m using:

  • Windows 7 SP1 64bit (fully updated)
  • VMWare Player 4.0.3 Build 703057
  • CIS 5.10.228257.2253

Please test and fix this.

[attachment deleted by admin]

At which point are you getting the errors, when you launch VMWare Player or when you launch a VM. Also, are you using a standard user account?

Thanks for asking that, i forgot to point it out clearly.

The VMWare Player starts as usual even with CIS, but when i want to actually start the VM (by clicking “Play virtual machine”) i get those two errors and VM never really starts after that. Just nothing happens after i dismiss those two errors.

I’m using the usual Win7 account (UAC in it’s default operation), no special limited treatment or anything, the way it comes from stock installation.

Confirmed. These errors occur when using a standard (non-administrative) user account.

If this is new to 5.10, unless someone else has some input, you should file a full Bug Report

See https://forums.comodo.com/bug-reports-cis/vmware-workstation-80-doesnt-function-properly-with-comodo-firewall-58-t76396.0.html. I think this is the same problem.

Looks like the same thing. He’s using VMWare Workstation version but i think the whole underlaying system is ientical for both (i just have a lot less settings).

It may be helpful to add your information to that bug report as well.

I can confirm this issue.