VMware guest unable to access network

I’ve recently started having issues with my VMware guest being unable to access the network when the NIC is set to bridge mode.

What I know so far:

  • When I uninstall CIS the guests are able to access the network.
  • Exiting or disabling CIS does not fix the problem.
  • My guest is definitely bridged to the correct NIC (Intel Centrino Advanced-N 6230 wireless adaptor)
  • When the guest is set to DHCP I can see the handshake process with Wireshark, with the transaction ultimately ending with a NAK from the guest, at which point the process starts again with the DHCP server (my router) providing the next available address.
  • Setting a static IP in the guest doesn’t make any difference.
  • The guest (Windows 7 x64) believes it has an IP conflict with the host

While trying to figure this out I’ve done the following:

  • Create a new guest from scratch with a clean installation (issue still exists)
  • Change the guest NIC to NAT mode (issue doesn’t exist)
  • Reset all CIS firewall rules to defaults (issue still exists)
  • Disable all CIS components (issue still exists)
  • Exit CIS (issue still exists)
  • Uninstall both my AV (avast!) and CIS (issue doesn’t exist)
  • Uninstall avast! and only have CIS installed (issue still exists)
  • Uninstall CIS and only have avast! installed (issue doesn’t exist)
  • Reinstall VMware (issue still exists)

PC Setup:

Windows 7 x64 SP1
VMware Workstation v8.0.4
avast! Antivirus 7
CIS - Latest version

At this point I’ve run out of things I can think of to try. Does anyone have any other ideas as to what the problem could be?

Dear Sir,

I have pretty much the same problem.

Have you found an answer ?


I guess i had this same issue, didnt tried all these things you tried but well hope its the same so you can fix it the way i did
on guest cmd

“netsh interface ipv4 show interface”
i will show up a table like this

Idx Met MTU

1 50 4294967295 connected Loopback Pseudo-Interface 1
8 20 1500 connected

then find which is your network card ldx number, there is ‘8’ , then

“netsh interface ipv4 set interface 8 dadtransmits=0 store=persistent”

then disable and enable the network device(still on guest)

well, this fixed it for me, hope does the same to you