VM XP guest: Continual cpu spikes [M875]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: Always
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    a: Installed Comodo Firewall (the firewall-only version that comes with HIPS). CPU spikes once every 30 seconds in vmtoolsd. Also on shutdown vmtoolsd is unresponsive according to Windows.
  • If not obvious, what U expected to happen: vmtoolsd to continue functioning as normal
  • If a software compatibility problem have U tried the conflict FAQ?: No, where is it?
  • Any software except CIS/OS involved? If so - name, & exact version: VMWare Tools Daemon v9.2.4 build-1398046
  • Any other information, eg your guess at the cause, how U tried to fix it etc: [color=green]
    Please note I am running Comodo Firewall --same version but x64-- on a Windows 7 x64 guest and there are no spikes.
    I reported another issue where I am having Cut and Paste issues between the host and the guest but was advised by the moderator to split off this issue separately. For reference the original thread is here:
    VM XP guest: Cut and paste doesn’t work and continual cpu spikes in vmtoolsd - Bug Reports - CIS
    The spikes are exactly once every 30 seconds. There are two instances of vmtoolsd running (this is normal: one runs as a service and one as the logged in user) and the spikes are coming from the service one. I’m guessing it’s trying to communicate with something and can’t. A screenshot is included below.
    vmtoolsd is classified as a Trusted File by Comodo Firewall.
    [/ol]

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.3.302093.2976, Firewall only version (Firewall+HIPS). Default and disabled tried.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Doesn’t matter
  • Have U made any other changes to the default config? (egs here.): Yeah I tried to add vmtoolsd after cut and paste stopped working but it didn’t make a difference.
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: Not relevant
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: No
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: XP SP3 x86 administrator account
  • Other security/s’box software a) currently installed b) installed since OS: a=none b=none
    [/ol]

Comodo diagnostic file attached.

[attachment deleted by admin]

The CPU spikes themselves may not be due to a bug, but just to the way in which Comodo Firewall works. If VMWare is trying to access protected memory locations it would be blocked by Comodo Firewall, regardless of which components were disabled. Thus, if that’s what the spikes are from, it’s not a bug in Comodo Firewall but just the way it works.

However, you had mentioned that there was another issue about vmtoolsd hanging when being shut-down. When you say hanging do you mean that it never finishes, and always must be killed manually? If not then how long does it hang for?

Also, with the CPU spikes you are noticing, do you notice any performance issues related to this?

Thank you.

The thing is I’m using Comodo in a Windows 7 guest and I don’t have this problem. Cut and paste work and there are no spikes.

I mean when I go to shutdown Windows XP wants me to manually end the task. There is a progress bar and it is waiting for vmtoolsd to end but it never ends so I click the button to end it and then the VM will shutdown (or reboot).

No, but that’s only because I’m not using the VM until I can get this resolved or I uninstall Comodo in this VM and replace it with a different HIPS/Firewall. You may note I uninstalled it at your request but I saved a VM snapshot before I did that and reverted back. I need some protection from something and for right now I have Comodo installed. If you mean can I type in it and do ordinary things besides cut and paste between guest and host then yes I can, the system seems to be otherwise unaffected.

Okay, now I think I understand the situation better. I have edited your first post so that it is entirely in the format preferred by the devs. Please look it over and make sure that I have not made any mistakes when moving the information around.

Thanks.

Looks good, thanks.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Can you please check and see if vmtoolsd is classified as a Trusted File to Comodo Firewall?

Thanks.

Yes, it is.

Thank you. I have updated this information both in the first post and in the tracker.

Can you please check and see if this is fixed with the newest version (7.0.313494.4115)? Please respond to this topic letting us know whether it is fixed or if you are still experiencing the problem.

Thank you.

PM sent.

This is fixed in version 7.0.313494.4115. Thanks for your help and thanks to the developers for fixing it!

Thank you for checking this. I have closed this entry in the tracker and will move this report to Resolved. If the issue reappears let me know.

Thank you.

I’m still seeing spikes every 30 seconds but they’re less severe and I didn’t notice them at first. Also as I acknowledged in the other thread the cut and paste is now working between Win 7 host and Win XP guest.

Here’s a screenshot from Process Explorer showing what it looks like:

I’ll move this back to the main bug reporting board for processing. However, I will not reopen it quite yet.

Is the problem with vmtoolsd hanging still occuring, or has that been fixed as well?

Thanks.

Thanks. The hanging on shutdown no longer happens. FYI I received duplicate e-mail updates for this thread.

Thanks. I have now re-opened this in the tracker and will move this back to the format verified board. I’ve also updated this to show that the only problem remaining is the CPU spikes.

Thanks again.

Hello,

I have exactly the same problem. I couldn’t find the bug tracker to check if there is progress on this issue yet, can you please point me to it (if it is public, that is)?

The tracker is not public. However, I just checked it and the devs have replied that apparently these spikes are not related to CIS. Thus, I will move this to Resolved.

copacabana, if you find evidence that these spikes are indeed related to CIS please let me know and I will look into this again.

Thank you.