VLC player and random progs visually blocked [V6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.
Programs get randomly blocked visually. They start and if you, i.e., start something like VLC player you can listen to the sound and see a working miniature in the task bar generated by windows but you can’t maximize it.

  • Can U reproduce the problem & if so how reliably?: Random, it just happens and sticks there until a reboot.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened: Can’t seem to find a specific trigger.
  • If not obvious, what U expected to happen: Obvious
  • If a software compatibility problem have U tried the conflict FAQ?: Malwarebytes Anti-Malware 1.75.0.1300 Pro edition.
  • Any software except CIS/OS involved? If so - name, & exact version: The latest VLC player (can’t open it to see the exact version but it’s up to date so it’s just what their website shows as current) and random programs here and there.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: Guess it prevents visualization because of some random effect.
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)
    [/ol]
    Appended CiS diagnostics, a dump from VLC and a general CIS dump (feel free to ask for something else, this is all I could think of).

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: CIS 6.1.276867.2813 and virus database 16405

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: Everything enabled.
  • Have U made any other changes to the default config? (egs here.): Nothing of importance
  • Have U updated (without uninstall) from a CIS 5?: No
    [li]if so, have U tried a a clean reinstall - if not please do?: Done
    [/li]- Have U imported a config from a previous version of CIS: No
    [li]if so, have U tried a standard config - if not please do: Done
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: Win 7 SP1 64 bit, UAC off, Admin, No VM’s running.
  • Other security/s’box software a) currently installed b) installed since OS: a= Malwarebytes Anti-Malware 1.75.0.1300 Pro b= same
    [/ol]

[attachment deleted by admin]

Please provide more details for B2 and B3? For example, did you switch to proactive security, did you enable the HIPS, did you add any Defense+ rules, etc…?

In addition you must also attach a watch activity process list. Please ask if you have any questions about how to do this.

In addition please answer the following questions so I can better understand the bug.
Are you running VLC player in the Kiosk?
Are you running it as Fully Virtualized?
Or are you running it on the real computer?

Also, can you please disable Malwarebytes and see if the problem re-occurs?

In addition, if the problem still occurs with Malwarebytes disabled, please try disabling the BB and HIPS and see if the problem still occurs?

Please report your findings back here.

Thank you.

It’s really hard to reproduce since I haven’t found the culprit yet so it might take a bit before I have valid answers for you.

HIPS is on and the rules have been added automatically, I didn’t do anything manually yet because of the previous bug I reported, if I need to do something and it’s all tweaked out already it would just be annoying to reset it :P.

I just checked the rule though, it isn’t blocking anything, the VLC app is either allowed or on “ask”, the weird thing is, I left the comp on for about an hour or 2 and it did maximize so it seems like it’s working with alot of latency (this wasn’t the case when I was using v5.x, nothing else changed on my comp but CIS).

I turned MBAM off for now so i’m gonna check what happens and i’ll just work my way down turning off defence etc., the issue doesn’t seem to occur while using Media Player Classic so there’s no hurry :stuck_out_tongue:

Have you been able to reproduce this yet?

PM sent.

Okay, for the time being I will move this bug report into the Non Format Issue Reports section. As soon as you are able to reproduce the bug, and attach the process list, I can move it back. Once you have done this be sure to send me a PM to alert me to the changes you have made.

Thank you.

Can you please check and see if this is fixed with the newest version (version 6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Also, note that all bug reports in the Non-Format section of the forum, which is where this report currently is, are not looked at by the devs. Thus, if the bug you were experiencing is still not fixed please edit your first post so that it is in the correct format (found here, with all required attachments, so I can forward this to the devs and get this problem fixed.

Thank you. PM sent.

This seems to be fixed, I haven’t noticed any “randomness” since the last update :slight_smile:

Thanks for checking this. I’ll move this to Resolved.

However, if the issue returns please send me a PM and we can move it back.