VLC and Microsoft Virtual PC(Manual sandbox):read/write permissions[Issue Report

The bug/issue

  1. What you did: I put VLC in the Manual sandbox (always sandbox, partially limited) to watch videos (AVi, MKV, MP4, etc). Regarding Microsoft PC i put it too in the MS (i use the MS in Microsoft PC as an other layer of protection when testing malware in a Virtual Machine).

  2. What actually happened or you actually saw: In VLC when i tried to watch videos everything worked fine (VLC immediately started) with AVi, MKV, etc, but for MP4 files, VLC took almost 3 minutes to start.
    Regarding Microsoft PC, the first time i started inside of the sandbox it took too almost 3 minutes to start.

  3. What you expected to happen or see: An instant start (seconds) on both programs.

  4. How you tried to fix it & what happened: I started the applications out of the sandbox and everything worked instantly.

  5. If its an application compatibility problem have you tried the application fixes here?:

  6. Details & exact version of any application (execpt CIS) involved with download link: VLC: Official download of VLC media player, the best Open Source player - VideoLAN, Microsoft V. PC: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=28c97d22-6eb8-4a09-a7f7-f6c7a1f000b5&pf=true

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: yes. Just put both programs in the Manual sandbox and start them.

  8. Any other information (eg your guess regarding the cause, with reasons): In both cases the problem reside in the fact that the files (MP4 and “New virtual machine hard disk.vhd”) are copied to the sandbox (VritualRoot) and both are large files (over 1,5 giga). In vlc i suspect the program is saying that is going to write to the file (MP4) but in the end is not (just reading), and because of that it copies the files to the sandbox. For example when using The KMplayer program (virtuallized) for MP4 files, it does not copy the files to the sandbox.

Regarding this matter (to much time to start, when the program has to write to the file), Moderator Mouse suggested a progress bar. https://forums.comodo.com/format-verified-issue-reports-cis/no-video-sound-in-manually-sandboxed-browsers-266-t61729.15.html#bot

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:

  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:

  3. A CIS config report or file.

  4. Crash or freeze dump file:

  5. CIS version, AV database version & configuration used: CIS 5.4.189822.1355, 8834, Proactive configuration

  6. a) Have you updated (without uninstall) from CIS 3 or 4: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

  7. a) Have you imported a config from a previous version of CIS:No
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

  8. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):Automatic Sandbox: Blocked. In the “firewall behavior settings” “advanced”, everything is ticked except “Monitor NDIS protocols other than TCP/IP”.

  9. Defense+, Sandbox, Firewall & AV security levels: D+=Safe , Sandbox=Enabled , Firewall =Safe , AV = Stateful

  10. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 home premium, SP1, 32 bits. UAC at maximum, SUA. I have an other computer with the exactly same configuration but it is a Windows 7 ultimate 32 bits with SP1, UAC at maximum and SUA (i have the same problems in both computers)

  11. Other security and utility software installed: Emet 2.0 on both computers. On demand on both computers: Malwarebytes, SAS, hitman pro and CCE 1.6.183539.73.

  12. Virtual machine used (Please do NOT use Virtual box):

When using an other sandbox (sandboxie) with VLC with MP4 files (over 2 gigas). VLC starts immediately, no file is copied to the sandbox.
Regarding Microsoft Virtual PC i will try it later

Did you try the application fixes under point 5?

No.
I just made the bug report because Moderator Mouse said it might help improve the virtualization process for V. 6 of Comodo.

I still have VLC in my computer, but i just do not use it anymore (but the problem persists), i switched to Kmplayer, because it does not give me any problems.

But VLC is very, very popular so it might be a problem to others, present (V. 5) or future (V.6).

But thanks for the help.

Thank you for your Issue report.

Moved to verified.

Thank you

Dennis