vlc and incoming authorisation

Hello,
I’m french so excuse my bad english…
I have a problem with Comodo and VLC Official download of VLC media player, the best Open Source player - VideoLAN. VLC is a media player that can manage streamings and I have the possibility to look at TV with it…if Comodo is not active. I did not manage to create a rule to permit VLC to read these streamings (I had no problems with other classical audio streamings).
Here is a capture of the activity
http://li.an.free.fr/comodo_vlc.jpg

The second line is the difficult one (port is changing with channels from 1880 to ?)
You can see parameters needed for other firewalls here (in french)
http://www.tvfreeplayer.com/?module=tutos&tuto_id=42
Thank you for an eventual answer…

Hi,

According to the web page, you can create Look-n-Stops settings in CPF Network Monitor rule. And make sure to move up the new rule above the last rule.

Let us know if it helps,

egemen

Thank you for your help Egemen, but it did not work (I hope I create the proper rule). I will try with next version of Comodo. Il would be sad to change for another firewall for this problem…

For me it started working only after I’ve created an allowing rule for IGMP traffic, tweaked flood detection (BTW, is there a way to turn it off completely?) and rebooted the PC.

Can you post the exact rule you created please ? (I’m french so I’m not sure I’ve understood your explanations). ::slight_smile:

The rule set depends on what type of protocol uses the server. I use VLC for watching IPTV (UDP Multicast streams) and the following allow it:

  1. ALLOW IP IN or OUT FROM IP [Any] TO IP [Any] WHERE IPPROTO IS IGMP
  2. ALLOW UDP IN FROM IP [Any] TO IP [Any] WHERE SOURCE PORT IS [Any] AND DESTINATION
    PORT IS 5500 (5500 is the port specified in stream URLs).
  3. Also I’ve set flood detection to its maximum values (effectively disabling it, I suppose) and disabled protocol analysis and fragmented datagrams blocking. Don’t know if it particularly has effect on VLC, I set these values for P2P apps.

Thank you djet.

Well, I still have a problem with VLC multicast - when I run VLC, it is shown in activity monitor and receives a lot of data (as it should) but I get no video nor sound. What is strange, that even disabling Comodo doesn’t help, but uninstalling does. Does anyone have an idea what to do with it? :slight_smile:

What does your log say when you try to use video?

that’s the worst thing - it says nothing :slight_smile: just an information about allowing incoming udp, 'cos i turned on logging of this, but nothing about blocking… but asi I wrote - disabling Network Monitor or whole Comodo is no solution, the only thing I can do is to uninstall it to make the TV work. but I’d like to solve this as I really like other Comodo’s features compared to for example Kerio :slight_smile:

Do you have a router?
Have you made a trusted zone? (security/tasks)
Have you made rules for allowing IGMP?
Have you tried to turn off “do not show alerts for applications certified by comodo”, in security/advanced/misc?
In the same place, check the “skip loopback…TCP” and raise the alert level slider to the top. Now try your multicast and see if you get some popups you can allow.
Check the log if something gets blocked during your multicast.
If nothing works, you could try the latest beta and see if it works.

Do you have a router?
no, i am connected directly to the internet :sunglasses:

Have you made a trusted zone? (security/tasks)
no, i didn’t set up any trusted zones, but that shouldn’t matter when disabling the firewall

Have you made rules for allowing IGMP?
of course :wink: and i do see it applying in the log

Have you tried to turn off “do not show alerts for applications certified by comodo”, in security/advanced/misc?
an alert was shown when first starting vlc, so i allowed it… i didn’t try this feature

In the same place, check the “skip loopback…TCP” and raise the alert level slider to the top. Now try your multicast and see if you get some popups you can allow.
okay, i’ll give it a try once more i have free time to experiment with my firewall :slight_smile: now i am running kerio because of watching TV :wink:

Check the log if something gets blocked during your multicast.
nothing gets blocked except for some users trying to access my forbidden sharing of files and printers in windows… to say it in a different way, i do not see any extra blocks after starting vlc

If nothing works, you could try the latest beta and see if it works.
i am running latest beta :slight_smile:

thx for you effort, i will try “skipping loopback” option you mentioned as i will have time and i’ll get you know about how i succeeded :wink:

well, it works now and i really don’t know why :smiley: i just defined the two rules mentioned above, set the flooding detection to max, allowed vlc.exe at first running and that’s all :slight_smile: thanks to you all :wink: