Vistax86 Reports Filesharing Turned On By Firewall [Solved]

When I open my ‘Network Connection and Sharing’ window (right click on the network icon in the taskbar) it reports that filesharing is turned on. I cannot turn it off because it tells me that “You can use your firewall program to change this setting”. Where do I turn filesharing off? I had it turned off on purpose and here is another example of Comodo deciding it knows what I want (llike trying to install w/out Defense +…you can’t). This is much more irratating then the control center of 2.4 asking if I want additional Comodo products…at least it would just ask and not decide this for me. Although I cannot profess total knowledge of the best security settings, I do know I have no need to have filesharing turned on. Vista works fine with it off and I don’t need that hole in my security. Please do not respond to this unless you are having the same problem or know how to fix this. I have no need to know why others would want it on. I only say this as to my past experiences posting to this board and can do without the frustration. Thank you very much.

[attachment deleted by admin]

it can’t be turned off when the vista FW is off some some strange reason but you can set comodo to block all incoming connections so it doesn’t really matter

I have gotten a better answer than the one that led me here from support ticket, but thank you. My major concern is the conflict, which I know from development of third party players, that is taking place in some level or layer. I actually have most of my system locked down though various means (i.e. hardware, software, etc…) but know that when windows wants something to happen, it wont matter what the software I have loaded onto it says. This also comes from being a windows user for far too long but unfortunatly I am not familiar enough with Linux that I can switch and still use the apps I want from windows.