Vista Welcome Screen Hangs [Merged/Renamed)

Ok. I liked comodo but not anymore after I spend several days to figureout that comodo is the culprit causing my laptop to screw up. Here is what happened:
After restarting win vista home basic, i entered log in/password. Now the welcome screen stayed forever and can’t log in. Only option is to shut down by holding the power key. But I can log in in safe mode with netwroking easily. Everything works fine. it turned out that the latest update from comodo screwed up my system. I uninstalled comodo. Wow. Everything is fine and computer restartes in seconds. I have avast antivirus and not sure if this latest comodo does not like that!

To double check, I just installed comodo and it asked for restart after installation. Now it is stuck at welcome screen again. So it is the problem maker.What a shame for a firewall product which is not a beta release or alpha that such serious bugs expected!

I tried 3.8.65951.477 and 3.8.64739.471 versions with no difference on win vista home basic. Is this a known problem? I already see a lot of issues reported in this forum about new v3.8 in general.

Anyone to help on this ?

Hello, newuser2009. Welcome to the Forums.
When you installed CIS, did you disable Avast’s on-access scanners first?
Sometimes CIS does not install properly when an AV has a scanner active.

No, I did not disable avast on-access protection. Because I never required that in the past. It always worked smooth. Why this version 3.8.xxxx will be such a mess?

I tried everything like disabling comodo on start up, no luck. I am now worried about my system as I am doing so many improper shut downs to play with this issue.
After booting in safemode, i also ran diagnostic tool in comodo and it says it found some error in installation but can’t fix it.

Ok, Here is the update and it might help others too.

  1. On my win vista home basic(32bit), disabling avast on-access protection and then installing comodo did not help. same problem.
  2. On my win vista home basic(32bit), uninstalling avast and then installing comodo, did not help either.
  3. On another machince with win xp, both comodo and avast installed. Works fine.

So, my conslusion is that the problem with comodo and win vista basic combination.

My current solution: Uninstall comodo and look for older version if I can find one. I will keep my avast as I like it as the best.

Hope comodo fixes this issue soon before they frustrate more people like me and also take care in future when they release any update. A poor guy like me will simply fall in the trap and check for update only to get a scrap.

Should this be a “Vista Home Basic” issue, or could this appear on other Vista releases also ?

I’d like to test if i have the same problem on Enterprise, can you tell me the Avast version you used and what settings you had active for it ?

I don’t know the exact reason why comodo did not work but for my settings, looks like it is comodo vista combination or something else I don’t know.
I am using avast home edition v4.8.1335.This is the latest version. Default install out of the box.

I have installed Avast without any problem, it reboots fine, it alerts, etc all is working here, there must be some other driver/service conflict during system boot, could we try to list your services and drivers to see what else is there that could be causing this ?

Can you download “Autoruns” from sysinternals/MS ?

If you install that and run it as Administrator, there is an option under Options that hides MS and Windows entries. Check that one and press F5, that should cause a rescan.

Can you please check the Services and Drivers tab and see what’s left there ? Maybe post a screenshot of it or else PM if you would like to keep it of the board ?

As I said, I don’t believe avast or any other software has anything to do with it. It is something with comodo related to vista platform as it works with xp.

Anyway, here are the screenshots.

[attachment deleted by admin]

Hi newuser,
It’s not Avast, it’s Vista.
I have Vista Basic on my laptop and have tried repeatedly to install CIS.
I get the same hang up at the welcome screen that goes on and on.
The latest version came up once normally but not since.
Now I’m running Avast, for the first time, along with Windows Firewall and SpywareBlaster.
Have SuperAntiSpyware, Malwarebytes and Ccleaner on demand.
On Windows Basic, 32 bit, I have uac, windows defender and the security center all disabled.

Different set ups, same problems with no solutions in sight.
When I posted this problem awhile back, never received any answers.
I don’t think they know.

XP is another story. Been running flawlessly. :slight_smile:

From the services grab you posted there I see a reference to Symantec.If you’ve previously used Norton therein lies your problem.It’s notorious for leaving stuff behind after an uninstall and it would certainly hinder you in installing CIS.I suggest you run the Norton removal tool or PC Decrapifier to clean up all traces then try CIS again.

Hi Danny.I put the same question to you,have you ensured all traces of any previous security apps were removed prior to attempting to run CIS?
Personally I always use Revo Uninstaller to remove any deeply embedded software as it’s surprising how much is left behind by some sloppy uninstallers.

It’s funny,
On XP, I tried just about every program out there.
CIS works great.
On Vista where I seldom change anything, has the problems.

I will give it a going over and let you know.
Thanks, Dan

HI Andyman35,
It is easy to confer problems to other softwares. Tell me why comodo worked so far until lately ? Norton or whatever came with my pc and expired after 3 months. I uninstalled and using avast since then. Same story with the xp machine that I have. So, i really don’t see why all on a sudden that will cause any problem.
Looks like more user is having problem on vista and I would rather assume comodo need to do something about it.
I can go through another time consuming effort to clean up my machine but I don’t think that will help the real cause here. Instead will only divert the issue of comodo vs vista home basic.

Update: I have run norton removal tool and that does not show up in services anymore. It was completely clean before with ccleaner etc and now just that one entry is gone. it does not make any difference to comodo issue at all. As I expected.

I’m deferring nothing,I’m not a Comodo employee so have no vested interest whatsoever,merely an individual taking a bit of time on a weekend to try and assist 88)

It may be an issue with Comodo but there are many thousands that have installed on Vista basic without issue,therefore the first step is/was to eliminate the most common reason for security software unable to install,a conflict with another pre-existing or incompletely uninstalled security app.

The fault may lie with an as yet undiscovered issue with the current version of Comodo but equally the problem may lie with another recently updated application having a bad interraction,as you say it worked fine until recently.It all depends how much time you want to spend at this but personally I’d try installing the previous version of Comodo to see if it’s this build at fault.

I appreciate your willingness to help. Do you know where can I find older veersion of comodo? I never kept track of it and also updated through update checker. So, Can’t tell which versions released when. I think problem started within last couple of weeks.

The version prior to .477 did not work neither did the 2 betas.
There was a version that did work prior to the betas but I’ll be damned if I can remember.
This is one of the reasons the problem lies between Vista and Comodo I think.

Thanks for wanting to help Andy and my system is clean.

Ok if required I found a link to version 3.5 here:

However it’d be better obviously to try to trouble shoot both your issues with the current version.I’d suggest you boot into safe mode and enable logging in order to see exactly which component is causing the system to hang.In case you’re unsure of this a guide is here:(ignore any XP references).

You can post the results here and at least we’ll be nearer to a cause. :wink:

I installed version and installed firewall only(no defense plus). It worked. So problem is narrowed to defense plus.


I’ve heard from Dev’s that they have changed a few settings for v3.9.x, you could also try to restart and test with those “non” MS drivers disabled to see if you can pin-point it to a specific driver conflict.