Vista Service Pack One

Has anyone installed Vista SP1 yet? If so, does it work with Comodo Firewall OK?

Anyone who needs the d/l link click here:

I tried it with comodo installed last night and my computer would not even boot up. BSOD even in safe mode. I had to rebuild my computer. SP1 is now installed without comodo. It went OK until the last reboot. It was like the problem with windows update in an earlier version but worse as it left the computer completely non-functional.

Man, that’s not good. Thanks for sharing.

Anyone else had any experience with Comodo Firewall and SP1? I’m just deciding whether I should risk installing it or not. From what tcarrbrion has said, so far it’s a big NO!

I have had Vista SP1 installed for a long time. I have the integrated disc and so I reformatted and installed Vista SP1 then comodo products and everything is perfect. MS recommends installing SP1 on a clean system. For those that don’t have the integrated disc, install vista, install the needed update (listed in the readme for SP1), then install SP1. Then do a regular Windows Update to grab the new drivers. :slight_smile:

If you do not want to reinstall everything, the recommended method is to completely shut down all Firewalls, Antivirus, malware scanners: so, CFP3, BoClean… so on. Completely exit them and go to task manager to make sure they are not running, and then install SP1. In fact, shutdown most programs running in the systray, and do not have any other program running during install. To have anything in the background running is to risk completely hosing your system … as someone else mentioned in this thread. :wink:


Excellent, that’s very helpful thank you.

I think I’ll risk it, but before installing I’ll uninstall CFP and reinstall afterwards.

I Installed SP1 to Vista Ultimate yesterday with CFP3.0.20.320; running with no problems. Didn’t shut down anything, just downloaded the standalone version (I was doing 2 computers) and executed it. So far haven’t seen anything to be concerned about. :BNC

I have VISTA SP1 integrated installed for a couple of months and had no problems at all :BNC

Installed it today. No problems whatsoever.

I read at TweakGuides it may be best/safest to use the stand alone installer vs. Windows Update.

I have installed Vista SP1 through Windows update, everything went smoothly but when my PC finished installing the update and rebooted it was having activation trouble, for some reason Vista didn’t want to activate itself with my product key :'(.

So I called up Microsoft, after about an hour and a half on the phone they told me it was a known issue for some installations of Windows Vista and they gave me a new Windows Vista Ultimate product key, it activated and here I am.

Wasn’t as smooth as I had hoped, but I suppose it could have been much worse.

I had to learn the hard way not to install SP1 without completely uninstalling CFW3. After the first installation, I lost all permissions to my computer, even to the point where I wasn’t permitted to shut down or restart the PC. I had to restore using the restore point before SP1.
CFW showed 2800 files waiting for review after restore, before uninstalling. After uninstalling CFW, reinstalling SP1 and CFW everything is OK again.
It should be a gigantic warning by MS or Comodo to uninstall CFW before SP1.

So far you seem to be the only user reporting a problem with installing SP1. I installed it a couple of weeks ago with no issues, and others have been running it for some time, as well as recent updates. Did you try a manual reboot with the power button? What were (are) your CFP settings? Did you get any messages from SP1 during the install? Did it install completely and then have problems, or stop during the process? Did you install from the standalone or from Windows Update?

To answer your questions:
Tried manual reboot after SP1 install completed, but the only way I could reboot is using the power button and even after that I could not access any of the programs or reboot/shutdown normally.
My CFP settings were/are default, I did not change any settings.
Sp1 installed from standalone, normally , no error messages.
A I said, I reinstalled everything again, (SP1 first, that CFW) and everything is working fine.

Sounds like possibly explorer.exe or wininit.exe got blocked somehow in the process. I also used the standalone but didn’t get the problem. Glad it is working for you now at least. :slight_smile: