Vista problem

I have been a Comodo fan for sometime now but after a number of problems with V3 and my newly installed Vista i decided to take the plunge and invest in Kaspersky internet security. Now my question is when i open the Security centre i am informed that 2 firewalls are currently running ie Comodo and Kaspersky…Comodo has been uninstalled…can anyone tell me how to tell Vista that Comodo is no longer on my PC? (V)


I’m not sure if it’s the same for Vista, but try this:
Open the start menu and clcik Run, and write cmd. Now type NET STOP WINMGMT /Y and then close the command prompt window.
Go to WINDOWS\system32\wbem and delete the folder Repository. Reboot windows. The folder will be recreated by the Security Center and should now display the correct information.


Thanks for your quick response Ragwing, i’m now going to show my complete ignorance of Vista!! How do you get to the run command or option? (:SHY)

Just press START - The Vista Icon (:WIN) and in the search bar type RUN :■■■■

I’ve tried what you’ve said but i get a message saying access is denied…never mind Vista may think that two firewalls are in operation but i know better!!

Thats was an expensive move. Should have read this and kept Comodo since its free.

I don’t need to be told how good Comodo products are…we’re all reading from the same page my friend. For you information my brother in law parted with the cash and gave me one of the three licences, so the moths in my wallet are quite safe for the time being. (:WIN)

Try turning off UAC-that fixes a lot of these type Vista problems. Go to contol panel/user accounts and there is a conveient off/on switch at the bottom.

Wasn’t trying to be snotty. I was merely trying to point out that if used Comodo and Avast free you would be just as secure as KIS.

Like i said we’re both reading from the same hymn sheet…and i didn’t think you were being snotty (:HUG)

No luck with that suggestion…thanks anyway.

You could try the command prompt and right click Run as Administrator this sometimes works for me when I get access denied.

I’ve tried this again and and i think we’re on the right lines but i get a message saying system error 5, access is denied, what do you think?

Click Start
2. Type: cmd
3. Right-click cmd when it appears under Programs
4. Click Run As Administrator

Type the following command:
winmgmt /verifyrepository
If the system returns “WMI repository is not consistent”, run this command:
winmgmt /salvagerepository
The first time you run this it will fail. (It will issue stop commands to the services causing it to fail. It might take a couple minutes for the services to shut down). Run the command again. You actually may have to run it 3 times before it finally runs and completes on its own.
Reboot your system.


Thanks N.T.T.W but i’m afraid you don’t get the cigar, i tried what you suggested but after getting a message saying WMI repository is consistent the security centre is still under the impression that Comodo firewall is there and running!!!

You could try the reset repository command:

winmgmt /resetrepository

This should reset the repository to the settings when vista was installed. Not sure if you need to re-boot for this to take effect but cant harm to re-boot to be sure.


If you start your computer(F8 Choose option) in Safe Mode with Command Prompt (Admin Account) it will reset repositry worked for me then type in the command prompt shutdown/r (This will restart your computer)

Thanks for your help I had uninstalled CPF3 for now will install again after next version is released.
It did not work at first came back with cannot shutdown service which has dependences but worked in Safe Mode with Command Prompt.
Thanks Again Dennis

Thanks Dennis for yet another suggestion, can i get this right first, are you saying boot up in safe mode (admin) and the enter winmgmt /resetrepository??

I’m at work at the moment but i will try it when i get home then i’ll get back to you and let you know how i’ve got on…cheers.