Vista hanging at Welcome Screen and ctrl alt del boot to desktop

???For a while now I have been reading other posts about Vista Hanging at the Welcome Screen after a fresh installation of COMODO CIS. So Far the posts and replys from CIS techs are very vague and do not address the real problem! Many users just so happen to mention that they have a DELL pc that this problem has appeared on! I believe this is going unnoticed by CIS SUPPORT! There is a pattern here and it is being overlooked! This problem is not! Zone Alarm or otherwise! I run a Computer Tech Shop. I have done so since 1992. I have just a tad of experence in the Trial & Error Dept. What I have experienced since I have started using Comodo CIS and Recommending it to my customers is this:
I can load CIS with no issues on almost every XP & Vista machine I work on. Except!!! the following! Cis support take note!

Every dell inspiron 1501 laptop with either version of windows vista! gives this very problem! so guys if you have any interest in solving this conflict with your software
Get you 3 or 4 inspiron 1501’s with vista hb or premium (occurs with both VISTA’s, just not XP)
And you will be able to reproduce this problem every time! now i dont know what the hang up is with cis, these machines, & their configurations but it happens every time!

every dell insprion 1501 w/ VISTA OS that has come thru my door this year(since being introduced to COMODO) We have done a factory recovery! (Hitting F8 to use the built in factory image recovery method).
Then we UNINSTALL the Trial Versions of whatever virus protection they come with, usually Norton’s! In which case we have also tried to further ensure that no trace of Norton’s exists by running the Nortons Removal Tool, which seems to process and apparently remove some left behind registry entrys and whatnot! Install all Windows Service Packs and Critical Updates. Then Just like clockwork After an Installation of CIS and a reboot, it happens. it occurs every time. I am currently setting here using the 25’th or so dell inspiron 1501 i have experienced this exact scenario on! you’ve got to fix this. I want to recommend cis to these people and do over the phone before they bring me their pc’s. But every time one of these show up i just shake my head and hang it low because i know what i am in for! So finally i decided after once again checking with your forums and realizing this problem is still going mostly under the radar. It is a real problem and can be reproduced with little effort on your part. please redouble your efforts to look into and reproduce this problem with the detailed information i have now provided. This should be do’able. r & d simple trial & error guys come-on!

In closing… sure i could wipe out there factory recoverys and clean load vista. and this my infact avert the problem but the customer doesn’t want that. I dont want that! it trashes all their drivers and apps they get with their pc. Costs me alot more time loading and downloading their drivers and soforth. Some of the prloaded stuff is ■■■■ sure! But most of these people are on a tight budget and need the few good apps they would loose going the other way. and there were only like several hundered thousand dell inspiron laptops sold with this configuration. we need this to work!

I am pushing for comodo, would even be willing to put up posters in my store front windows! send them to me, i will,if you fix this!

The computer guys of Bowling Green, KY

You will be assemilated! resistance if futile! ;D

Edit: Removed Capital letters.

Pls do not Post with Capitals, its like shouting and its rude.

Edited your post to remove Capitals

Yes, Thankyou for posting! They need to see that this is not some minor issue with some other obscure app. That its not only one or two people with a freak condition causing this.

it is across the board on any Dell Vista machines of that Image Restore. And also I have tried all of the other brands of virus protection, free or otherwise on these machines, and none of them create this Welcome Screen, Hang issue, Only CIS seems to cause this. I do believe it has something to do with Defense +. I have had some limited positive results by permanately disabling Defense + in its advanced options. But then that weakens the protection Barrier were trying to put up.

On a side Note.
I have had to Disable Defense + on some other machines including on of my own, because I started noticing some strange browser issues. Like when you do a task that brings up another box,say the print
dialoge, Suddenly u cant click on anything in that box till you click on some other program and then toggle back to that box and then it responds. Also being unable to click some “known safe” links on many pages were not responding. Simply by disabling Defense +; those quirks immediately went away. In all those cases I have experienced this.

In fact,I have had to walk a lady thru this today over the phone, for the very same reason.
That fixed the problem for the moment - and I told her, assumingly, that COMODO was working on the problem and would be releasing a fix for that soon so she could once again be fully protected.

Hope we can bring some light to darkness, Everyone please post your similar experiences or they will not know how big an issue this is. I think they believed they had found and fixed something related to this a while back, when in fact the problem still exists even now in their latest release.

Hmm, so this happens only on a Dell Inspiron 1501?

When I get home from vacation Nov. 1, I’ll find out how it does on a Dell XPS desktop running Vista Business.

Well I’m not saying this only happens on Dell Inspiron 1501’s, That would be unlikely, since many models of dell’s use this very simmilar Image for their factory recovery img file. I was trying to suggest if they want to troubleshoot this problem that In my experiences you can assuredly produce thiis problem with a Dell Inspiron 1501 Vista Machine with its factory recovery intact. I have 100% of the time I get this model in our shop! I can say that I have loaded CIS on other dell models that this did not occur, but they were league’s different in model and year producton. Their newest Dells obvioulsy have way different Images with many visable differences when First Booted out of the box.

!!! Update. That 1501 laptop I was on the other day when I submitted my first post, I was able to Successfully Disable Defense + (Permanently) And the machine does not hang at the Welcome screen anymore!
That being said you may have read another post I submitted about Defense+ and some strange problems. I should say those were not Dell Related and in fact were on two or three totally different machines.

I bellieve the Defense+ part of CIS causes these problems, that all these experiences are related to that part of CIS.

I have a Gateway laptop, Model MX8711, with Vista Home Premium SP1 that exhibits the “Welcome screen hang” anomaly. This began at version 3.10.10263.531 when I first installed CIS on the machine and continues yet today at version 3.12.111745.560.

While its true that disabling Defense+ prevents the anomaly from occurring, I’ve also found the anomaly can be prevented from occurring by simply unticking “Detect shellcode injections” and leaving all other Defense+ functions enabled.

I also have a Dell Inspiron laptop, Model 1545, with Vista Home Premium SP1 that is not similarly affected.

Howdy. I made a moderator mistake with merging. Your topic was temporarily merged with this topic: .

I split the relevant posts and regenerated your topic. The title may differ a little. When you think I forgot to split and merge one or more posts from the mentioned topic please send me a pm and I will fix it



I wanted to put a post here for anyone having the same issue with the Dell 1501 systems hanging at the Welcome screen. I had the same issue and it had nothing to do with CIS. I had just done a clean recovery of the system and uninstalled all the trialware and installed all the Winows updates when it started hanging at the welcome screen. Long story short somehow the user account had gotten added the the debugger users group once I remove the account from the debugger group and the account was only a member of the Administrators group the system started loading normally. Hope this helps anyone else with this issue.

Since posting to this thread 10/22/09, I have identified the file that doesn’t play nice with CIS Buffer Overflow Protection on one of my laptops. The file is mpnotify.exe located in Windows\System 32. I have not found that Windows or CIS Event Viewers record this type of anomalous startup event, so I had to resort to manually zeroing in on the conflicting file, which took about three hours.

If anyone reading this post is aware of user friendly third party software capable of detecting and recording this type of anomalous startup event, please post it here. Besides myself, I believe there may be others interested in being able to shortcut the identification process.

Note the subject anomalous startup event, which apparently affects some, but not all, computers, continues to occur with CIS version 4.0.