vista firewall keeps turning on

(B) (L)
ok so everytime i reboot my computer vistas crapy firewall will turn it self back on… i know how to turn it off but anyone know how to keep the stupid thing off? (:AGY)

You can try Control Panel > Services > Windows Firewall > Properties > Disable.

(Note, this will affect Windows event collector. For some reason the Event collector service depends on the firewall service).