[Vista, CIS 7] "COMODO Antivirus reports that it might be out of date" [Merged]

Just the last couple of days I have noticed that Windows Security Center has flagged the Malware protection as out of date, with the message “COMODO Antivirus reports that it might be out of date.” When I run Update from within CIS it checks and says that everything is up to date, but the Windows Security Center message persists.

Windows version is Vista, 64-bit. CIS version is 7.0.317799.4142, Database version is 18286.

Is this an issue with CIS, Windows, or something else? I have used “winmgmt /salvagerepository” in case the WMI repository was corrupted, but Windows claims that it is consistent.
Mod edit: Added merged to the topic title, Captainsticks.

Hi ftww,
There is an issue causing update delays on Comodo’s end causing the out of date message.
Comodo update servers down ?!

Kind regards.


Recently the Windows Action Center constantly reports that Comodo Antivirus is outdated, but when i run a manual update check from the CIS dashboard it says that everything is up-to-date. When i open the action center and click on update now it points to a file at “c:\Program Files\COMODO\COMODO Internet Security\cfpconfig.exe” but then nothing happens! I tried rebooting but the action center just keeps reporting the it’s outdated.

When i check the certificate details, the Key Usage & Basic Constraints fields have a yellow exclamation mark icon on them but it says that the certificate is good & valid up until 2015. Idk what the problem is…i did a full scan and found nothing to suggest that I’m infected. Btw this is COMODO Internet Security v7.0.317799.4142 downloaded from FileHippo.com and I’m on Windows 8.1 Enterprise 64-bit.

Hi and welcome PCUser-D,
I have merged your topic into this topic, you will find an explanation above for reason behind the ‘out of date message’.


For anyone totally annoyed with the ‘out of date’ message.
Note: This workaround will download the entire Database file again (Est 207 MB).

This workaround may not be elegant, but it will stop the nagging message (At least temporarily in the hope that the updates resume before the message returns).

  1. Rename the bxxxxx.cav file to bxxxxxold.cav.
  2. Manually check for DB updates and allow the DB file to be downloaded and installed.
  3. Delete the bxxxxxold.cav file. (Reboot maybe required to allow deletion).
    File found at the following location,
    C:\Program Files\COMODO\COMODO Internet Security\scanners

Kind regards.
Edit: Spelling correction.

Thank you for the explanation, workaround, and quick response, captainsticks. Much appreciated!

You are welcome, let us hope updates resume in the very near future. :slight_smile:

Database updates have resumed. :-TU