With Vista Home Premium, CFP seems to interfere with vista validation. Vista came preloaded with Norton which worked fine. Removed Norton and replaced with CFP 3 and Avast Home. Previous to install of CFP 3, no problem. Now, on boot, an intermittent problem occurred, giving an error related to validation of vista software. Problem occurred and fixed with Kaspersky (see: by delaying start-up of it’s “Pro Active Defense”.

Maybe start of CFP 3 can be delayed to solve the problem as well. Also, Id read to solve problem, can also “re-validate” vista at, but now vista will not validate, and it cites a list of “incompatible” software (which CFP 3 is NOT on/listed).

The problem is intermittent, usually after a re-boot, problem is gone, only to re-appear perhaps on the second or third next boot(s).

Anyone seen this behaviour? Even better, is there a fix? As far as I can tell, somehow, vista cannot validate itself because of CFP 3, and then enters a “Tampered State” which basically stops it from functioning.

I too have Vista Home premium and removed (with great difficulty) Norton Internet Security to install Avast and CFP 3.

The only problem I encountered was in removing Norton. After finding and removing various Norton files and registry entries by hand my new security software installed without hitch. Since then I have had no problems at all and the firewall and Avast work nicely on my Vista pc.

Is it possible some of your Norton installation has escaped removal. Might be worth trying the Norton removal tool though this still left one folder and some files on my pc which I had to remove manually.


Cheers. I did use the norton removal tool but didn’t think to look for remnants. I’ll give it a go, but I can’t understand how a folder or 2 could influence this kind of behaviour. But worth a try maybe. I think maybe CFP 3 loads at different times on different boots (if that is possible)…could explain why don’t see the problem every time…

Loads of NAV, Norton and Symantec garbage left was removed. But still having this boot/validation problem.

Do you see any events in D+ or firewall logs that could be relevant to the problem - any blocked microsoft files?

Does turning off the D+ and/or firewall make any difference on re-boot?

When I first installed CFP on my Vista system I temporarily disabled windows defender and UAC first, as well as turning off on-access scanning for Avast. I also disabled windows firewall in services. Once CFP was installed and pc re-booted I immediately switched both firewall and D+ to training mode. Also, I made sure the “Block all unknown requests if the application is closed” box was not checked in D+ settings.
I then re-booted again and turned Avast on-access back on as well as defender. I left UAC set at a low level using Tweak UAC:

When I re-booted with D+ on training mode there were a lot of balloon messages saying that various microsoft files had had rules set for them.
After this I ran through using all of my trusted applications and then set D+ to “Train with Safe” and Firewall to custom policy mode.

It might also be worth disabling Avast Network shield if you have it active.

I just thought I would list what I had done when I installed the firewall as it may give you some ideas that might help you.


Having the same problem. Vista goes back to log on screen after failing to validate. Only option was to uninstall Comodo through safe mode. Might try installing in safe mode.

Well the installation went well in safe mode, rebooted in safe mode and set firewall and D+ to training mode. Rebooted normally and the firewall was working. Unfortunately had the Vista pop-up again, needing validating, ten minutes later. Ended up in a Windows page informing me that there was an incompatible program installed and needed uninstalling. :THNK

Thanks N.T.T.W.

I tried a couple of the ideas you used (switched to training mode for firewall /defense +), turned off “Block all unknown requests if the application is closed” (which was checked)…didn’t make any difference. I do have the very annoying UAC permanently off, as well as Windows Defender…that and the removal of Norton actually make my new laptop run as it should…very fast!

I don’t want to uninstall CPF 3 since as I suspected (and now confirmed in subsequent posts) it won’t help, and for the most part, it is configured as I need it to be (so I think)!

What I would like to try, if someone can indicate how, is to delay whatever driver loads for CFP 3, since that seemed to be the remedy for users of Kaspersky software. Judging by the variety of positions of the CFP 3 task tray icon after boot up, I’d guess CFP 3 loads at different times (is that possible?)…when it loads “sooner”, I am denied logon…when it loads later, I’m in…maybe am wrong, but that may explain why I don’t have a problem everytime I boot/logon.

Also, I know my vista is genuine, unless the fraud begins with the “preload” on my compaq (not likely!)…so if someone knows a way to get around this constant and ridiculous re-re-re-re-re-validation process, but still allows for updating, then say the word!

Re-installed CFP 3(277), cleared registry entries, and followed post install directions as listed above. On 1st re-boot, I got the message that windows had an unauthorised change and could not proceed with the logon. I had set Defense+ to basic during the install. After trying many different settings in defense+ (including “disable”), I have have now made it “inactive”, and have not since had the logon problem. So it would seem it is down to the defense + without doubt. I did see some blocked entries for scvhost.exe in the log, but went through and added each one as “my own safe files” and each one was “already there as being safe”.

I guess it would seem that for some installations there will continue to be this problem with Vista. I’m sure I’m not the only to experience this. It might be an idea in the “next” update to have a look at why this might happen. Also, it might be nice to have the option to delay the start up of CFP 3, to at least help diagnose logon problems, and perhaps even solve them.