Vista 64x - Installer doesn't even get to the first screen....

so i have vista ultimate SP1 64x installed

i double click on the installer, it unpacks the real installer, runs it, and i get the message “COMODO Firewall Installer has stopped working. A problem caused the program to stop working correctly. Please close the program.” and then a button to close it


http://img151.imageshack.us/img151/884/comodoerroruw9.jpg

i tried installing comodo back at the beginning of 2007 and i got the same error. there’s no error log or anything so i have nothing to go off of

i don’t think i have any services turned off but are there any specific ones required for the installer to work?

it’s really frustrating because there aren’t very many firewalls for 64x vista and this is one of the few good ones. i have only SUPERAntiSpyware installed but i’ve disabled it. security center is disabled and UAC is disabled

Which CFP build are you trying to install (full name)?

ah can’t believe i forgot to include that. it’s the latest “CFP_Setup_3.0.21.329_XP_Vista_x64”

UPDATE: i was bored so i decided to try to install it in Safe Mode. BINGO it worked!! and now everything’s fine after a reboot. wonder why it worked in safe mode but not regularly ???