Vista 32 SP1 no longer sleeps after upgrade to 3.8

On upgrading to CIS 3.8.65951.477 the Windows Vista Home Premium with SP1 will not enter sleep mode. The computer screen turns off but the HD is still active and the system fan does not turn off. This is not a problem I had before I upgraded. I uninstalled the whole of CIS completely and can enter sleep mode without a problem. When installed CIS again I I have the same problem. Can anyone suggest a solution?

Just out of curiosity, do you happen to use the Foobar2000 media player?

If I leave it open, my system will not sleep. I suspect it’s something between its relatively new library folder monitoring function, and CIS keeping its eye on that process. (Whatever that entails…)

Welcome. :slight_smile:
Try setting D+ to “Training Mode” and then try to put your PC in sleep mode.
Also, check your D+ logs.

Thank you for the welcome. :slight_smile:

I’m not running Foobar2000 Media Player.

I’ve put Defense + in to training mode and tried again enter sleep but it does not appeared to have changed anything. I get the same response.

Looking at the Defense+ Log, I see a lot of Access Memory actions and the Change Defense + Mode (to Training Mode) but nothing that might indicate why sleep cannot be entered, at least as far as I can tell. Thanks for your interest and help. I hope with it I can sort this out.

I have also tried to enter Sleep with D+ disabled and it has not worked :frowning:

Did you reboot your computer after disabling D+?

Do you have the AV module installed? If so, what happens when you disable real-time scanning?

I didn’t reboot after disabling D+.

I’ve done so now and it works! I am able to enter Sleep mode.

I do not have the AV module installed.

I suppose the question now is do I need D+?! Perhaps I could reset the settings and start training again in case it was something I did not do correctly that caused the problem in the first place. If that is a good idea how do I reset everything that has been learnt already?

Well, CIS is considerably less powerful without D+, but really it’s your choice. I guess the question is if other Vista users are able to sleep after the update. I haven’t seen any other posts. If others are also experiencing the same problem, then it could be something you blocked that you shouldn’t have.

Like I already said, I can sleep if I don’t have Foobar2000 open, but I’m running Win XP Pro.

If you do want to clear out your previous policies and start fresh, you can find them here.
Defense+ → Advanced → Computer Security Policy. You can remove or edit any policy here.

What I am unsure of though is what the default settings for the Windows processes in the list are. I would imagine that one of these would be the culprit.

You could do a bit of troubleshooting before trying that though, based on my Foobar2000 experience. Foobar + Defense+ active = No sleep mode. However, if I disable D+, the system sleeps when Foobar is open. The system will also sleep when Foobar is closed and D+ is active. It’s the combo that is the problem.

Foobar2000 has a feature that actively monitors your media library folder so any file you put in your library is automatically added to the Foobar playlist. My theory is that this feature causes D+ some sort of grief and the system thinks it is busy so it doesn’t sleep.

Do you have any applications open that could be doing something similar? Will your system sleep if the only application active is CIS with D+ running? (Check your task manager (Does Vista have that?) to see if there are active services belonging to closed applications as well)

Sleep mode works fine here.
CIS 3.8.65951.477
Vista Home Premium SP1
HP Compaq

After having placed Vista in Sleep mode with D+ disabled I found that the firewall was also disabled. Not good I thought. I started the firewall in training mode (D+ disabled still). To my disappointment I cannot get Vista to enter Sleep mode now!

I disabled the firewall again and, after a reboot, I could enter sleep mode.

I went through the Network Security Policies and removed all the Application settings. Rebooted with the firewall in training mode (D+ disabled) to find I still cannot enter Sleep mode (also I have not received notices requesting settings info for processes requesting network access which I would expect. I am not sure I have deleted the settings properly).

Looking at the Windows Task Manager (there is one in Vista, short-cut: Ctrl-Shift-Esc) I do not have any applications running when trying to enter Sleep but have more processes than I would care to count!

In terms of processes that may be checking folders, I am running Live Mesh. What I don’t understand though, is why before I upgraded to 3.8, in think I was using 3.5.57, I could run D+ and the firewall and enter sleep.

Short of uninstalling CIS and starting again, what could I try next?

An update:

Re-installation of CIS solved the problem :slight_smile: