Viruscope silently conflicts with SMITE installation [M933]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.
SMITE is a moba game from hi-rez studio’s. Basically, a stub/launcher is installed which then goes out to pull down the install package and install the game. the stub and download work flawlessly, the installation process however hangs/freezes at random percentages of completion during multiple re-attempts. Normal install behaviour is restore however if Viruscope is disabled.

  • Can U reproduce the problem & if so how reliably?:
    issue is 100% repeatable.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1: download smite stub installer and choose to install game (example here, direct download)
    2: wait for the 4.X Gb install package to complete downloading
    3: observe the install % complete where the install just stops; no Viruscope popups or entries in log
    4: run the hi-rez diagnostic
    5: choose to re-install SMITE
    6: return to step 2
    Note: Once bored with cycling from step 6 to step 2, disable viruscope and continue at step 4 (now the install will complete/work)
  • If not obvious, what U expected to happen:
    The installation to complete.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
    Only the SMITE installer stub & package mentioned
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    Confirmed no issue installing/patching on a PC with CIS6. Under CIS7 I tried various combinations of enabling/disabling AV/Sandbx/HIPS… only disabling Viruscope let the installer/patcher function normally
    I see a couple options here:
  • SMITE knows viruscope is watching it and doesn’t like it (highly unlikely)
  • Viruscope has intercepted what the installer is doing, but failed to provide a popup for me to action (most likely)

[ol]- Exact CIS version & configuration:
7.0.313494.4115 (x64), ProActive Security mode

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    AntiVirus - Stateful
    Firewall- Safe Mode
    AutoSandbox - Untrusted
    HIPS - disabled

  • Have U made any other changes to the default config? (egs here.):
    a) ProActive Security mode
    b) HIPS disabled, create rules for safe applications
    c) Autosandbox enabled [at] untrusted
    d) Firewall advanced options enabled, trustconnect disabled, create rules for safe applications
    e) Website filtering has the hosts file from MVPS imported for blocked sites

  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    no, clean install of CIS7 with rating scan performed
    [li]if so, have U tried a a clean reinstall - if not please do?:
    N/A, but I tried that too
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    win 8.1 pro with media center x64, UAC off, admin account, not a VM

  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=N/A b=N/A

Is it possible to post a download link to an installer which the devs can use to test this?


Stub installer @

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

My first attempt at upgrading to the CIS8 RC failed. I have a bug reported, and have not yet decided what my path will be for my next attempt… try duplicate my bug, or completely uninstall CIS7 and try a “clean” CIS8 install.

Until then, I cannot validate this older bug against the new CIS8 version… but will keep it in mind.

Thanks. Let me know what happens if you are able to get V8 installed.

CIS 8 v4337 is installed and Viruscope is now enabled… just need to wait for the game to put out an update (they usually do one or two a month) to see what happens.

Looks like a minor update happened successfully today with Viruscope enabled, so that’s a good thing! Defense+ did it’s normal popup as the exe had changed, and all was well launching the game.

Another successful update, the same as earlier. However, this time I’ll point out that I am still not using Enhanced Protection Mode as I have an issue (I’m assuming) with the new VT-x code. Not sure if Enhanced Mode impacts Viruscope at all… so even though I’m taking a grain of salt with the unknowns… progress is still progress.


The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

I have a feeling that I’ve seen CIS version works nicely with the SMITE updater (with viruscope)… but it seems that my current config had viruscope disabled (I think I did that when I was playing with enabling HIPS and forgot to go turn it back on again when done), which means my recent update history/memory isn’t a valid benchmark.

I’ve re-enabled viruscope and will report back a definitive after the next update. In actuallity, I may have the recently available 8.2 Beta installed before then… so my validation might end up being against that version.

Keep me updated on the issue

I’m going to say it must have worked out okay, as I received defense+ popups due to changed files. I also installed the 8.2 public beta, so I can comment on this release as well.

This is great to hear. Im glad everything is working like it should. I will now move this to resolved and close this report in the tracker. If you experience this bug again in the future feel free to respond here or PM me and i will reopen this bug report.

Thanks again.

Reconfirmed in the CIS v8.2 Build 4474 public beta!


Thank you.

Sorry qmarius, i was referring to this bit…

I probably also could have been more clear… reconfirmed that the issue has also proved to be absent in CIS v8.2 Build 4474 public beta.

No reason to reopen, sorry for the miscommunication.

Ah okay. That’s clear now.
In the future, please do not mark (newer) fixed version if it’s already marked as fixed in an older version. No reason to do that. :wink:

In the meanwhile, moving this report to “Resolved” section.

Thank you.