Viruscope interferes with Nvidia GeForce driver update [M1012]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    I don’t know, not really interested in testing since I don’t like to mess with drivers.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

[li]I downloaded the latest Nvidia GeForce drivers for my GPU i.e GeForce Driver 337.88

  • I ran the installer
  • The installer did its thing but failed to install the basic Graphics Drivers
  • Tried disabling HIPS and rebooting - Didn’t work, driver still failed to install
  • Tried disabling Viruscope and rebooting - Worked, were able to install drivers.

[/li]- If not obvious, what U expected to happen:
I expected the Nvidia Drivers to be able to install successfully with Viruscope enabled.

  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
    GeForce Driver 337.88
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    My guess is that Viruscope is somehow blocking or interfering with the driver installation, no alert was ever shown.

[ol]- Exact CIS version & configuration:
COMODO Internet Security Premium 7.0.317799.4142 - My custom proactive configuration.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    AV - Stateful ; HIPS - Safe Mode (Tried Disabled) ; BB - Disabled ; Firewall - Custom Ruleset
  • Have U made any other changes to the default config? (egs here.):
    Yes, config file will be attached.
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    N/A (I don’t feel comfortable with testing this issue hence I can’t try a standard config, maybe next time Nvidia comes with a driver update, either way the Standard config doesn’t have Viruscope enabled I thing)
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 8.1 Update 1 64bit, UAC enabled, Admin Account, No VM used, (Gigabyte GTX 780 if relevant)
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=Zemana AntiLogger Free b=N/A

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I might add that it also seems to interfere with GeForce Experience updates, seeing as GeForce Experience is a part of the GeForce Drivers and probably employs the same technology as the driver installations, I feel it is appropriate to just add it onto this bug report rather than creating a whole new bug report.

Thank you. I have updated the tracker.

It appears that this is now fixed. I will therefore move this bug report to Resolved.

Thank you.