Virus update not working

The last few days, I have tried to download a new virus definitions list. The status bar gets to 30% and then stops. It announces that the internet connection was broken, and the download failed.
Is this some kind of anti-anti-virus thing, or something?

It’s still acting that way and I still don’t know what to do about it? Reload Comodo, or something? Is anybody else having this problem?
My personal photo enclosed to see how I’m tearing my hair out about this. Serious.

[attachment deleted by admin]

Seconded, my windows 7 went from saying should update comodo to turn on comodo please. >:O then i updated or tried to anyways update comodo and it said my connection failed even though i am typing here. on the internet.

Update your virus database manually:
https://forums.comodo.com/anti-virus-faq/where-can-i-download-the-latest-full-av-database-t47164.0.html

This should fix the problem.

Or, if you’re lazy, try this:
https://forums.comodo.com/anti-virus-help/virus-definitions-update-313125662579-fails-at-51-t49255.0.html;msg354504#msg354504

Same problem here…
my Win 7 box working fine. My XP netbook give “failed to update… check your internet connection” for nearly a week now. I’m posting here with that same netbook, so proof i’net connection is good.

might try the manual update, but shouldnt be required.

UPDATE: tried the lazy-man’s method (remove bases.cav, run diags, reboot) and it now has updated defs. Weird, but works.

Hi Im having the same trou.lbe. I have “updated” the virus database to 3460 by sustitution in safe mode but my computer and the Comodo pagwetells me the virus definitions are out of date HELP!!!

Official Post from Dev’s on update issues:

https://forums.comodo.com/feedbackcommentsannouncementsnews-cis/resolution-for-repeated-update-failure-t49493.0.html

Just FYI:

Anybody who will apply the workaround will not get the subsequent updates until tomorrow morning (USA Coast Time Zone)