Virus Definition DataBase Update

Dear Ladies and or Gents.
Hello I am a new user of your AntiVirus COMODO program, I aquired the free version via first I want to see how the Antivirus program works out first but I would like to convert all my security and software needs to one company to make it easier to keep track of, I’m contacting you because first of all this was the only way that I could find to contact you, so I will pose my problem to see if anyone can help me.? I have successfully downloaded the program via Tucows and it informed me that the download was successfully finished without any problems however it did advise me that the " Virus definition data base " was NOT up to date so I was directed to the Virus update link, I clinked on the link and the update began however it stops at 30% every time I try to update and I have patiently tried over 10 times, is this normal ? at present I have waited up to 8 hr’s. at 30% should I keep waiting could it still be working properly just taking longer when it has reached 30% or is it freezing/stuck there? I should tell you that the only internet connection in my area is dial up connection as I live in a remote area of West Texas, should I try again and just “wait it out” at 30% or should I uninstall and reinstall the COMODO Antivirus Program again, your help or direction in correcting this “problem” if in fact it is a problem or just a slow process due to my Internet connection? I truely am impressed and would like to convert all my internet needs to COMODO products and any of it’s availble programs that I may need in the future, another Great influence is it’s User Friendly layout, you guy’s have something Great all the way around, I picked your program from a list of AntiVrus programs that was not yet rated by anyone who had left any feedback, however I read the discription of the program and found that with no feedback not many people new what you guys were offering for free, that speaks volumes, not because I’m cheap or that anyone who looks at the cost and it says $0.00 " Freeware " is but it means you guys have something you know is more than good but that you’re giving the public a chance to try one of your programs and see how what seems to be and is an easy to use " User friedly " program but is also one of the best and complex in depth tools that can keep your computer and private life safe and secure.
So I’m asking for help,Does anyone know why my attempt’s to update virus definitions would stop or freez up at 30% ?

Any Help Is Greatly Appreciated
JD Nazario

If you’re on dial-up it takes a loong time to download ~100MB or so. It looks stuck but it should download in background.

I’m in Central Illinois, on a DSL and have had nothing but problems getting updated, or even the manual dl…
Took 4 retries to get the initial base downloaded… and over five hours waiting! Now, the programs update feature won’t even initialize, tells me to check my connection … meanwhile I was on their site, dl’ing the base!
Beginning to wonder if this ain’t one of those outfits that makes things impossible for those using their ‘free’ software!

From what version are you trying to update?

I have given up on the AV because of the update issues. I don’t know what is going on with the update service, but it has not worked properly for me in over a year.

My recommendation is to use another AV. Keep using the firewall and D+ as they are the best thing in CIS.


Well, it says is not found. That kind of explains why i can’t update my virus definition. Only happened around late april. When i used it last time, it never failed, now… i guess something must be wrong with the definitions.

Same question for you.


I have been using Comodo for quite some time. And today I downloaded the free new version (4.1.150349.920) of Comodo and installed it. While installing it deleted all the old files, including the virus database definitions. The new installation shows the virus signature database version as 1. When I am trying to update the database, it runs for sometime and cuts off in between. I attempted downloading it for more than ten times without success. One thing I noticed is that most of the time the cut-off happens when the downloading reaches about 30% or so. It is not an internet problem from this side.

Although I have experienced virus database update problem a few times earlier with the old version, it automatically solved trying at a later time.

I have read some suggestions in some posts, which did not help.

Appreciate guidance.


Going through other postings, I came across of downloading the file manually for this version, and replacing the bases.cav. I am downloading the definition file manually at the moment and shall post the outcome once done with.


Manually downloaded the definition file and replaced bases.cav as suggested in another post. Rebooted and working fine now. Sorry for not trying this before my first post.

Thank you for reporting back though. Somebody may read this and find the hint he or she needed.

For reference for other users. This is the helping topic: Where can i download the latest full AV database?.

I got the same problem: failed to update database (cis v3.14). It stucked at 30% after half an hour or so then said that my network had a problem. Then I try manual update, but the result almost the same: downloaded file stucked at 14.376.960. I have tried to downloading bases.cav and BASE_END_USER_v5154 from all server eu1, us3, us4 using browser IE, firefox, download manager flashget 3.5 and Free Download Manager only got same result: stuck at 14.376.960 Byte. Download manager said that there was no respons from server after downloading 14.376.960 Byte. Even if have try downloading via free proxy with same result: stucked at that magic number. Any idea?

My Comodo and Computer Info:
Comodo Version: 3.12.111745.560
Comodo Virus Signature Database Version: 3103
Computer: Dell Inspiron 1720 (Dual Core)
Running Vista X64
Cable Internet Connection

I tried disabling Defender, and CIS as moderator suggested…the AntiVirus Definitions still will not update–does not even run/try and time out, it immediately pops up the FAILED ERROR BOX. I thought it was the server yesterday, and tried again late last night-just before midnight, then again after midnight hopeful in thinking the Comodo System would reset at midnught, but no luck. Thus, I tried again this morning–to no avail, and it is not auto updating either(obviouslly, or I would not be here ;D). I went through everything I could think of that could be blocking the update…
When nothing worked, I came here for answers. I see that many others with Vista X64 and also XP, and other systems and other versions are having the same issue over the past few days–while for some it appears this has been an ongoing issue. I, however, have never had a problem before with the AV Definition Updates–only maybe short-term…where an error would appear once, but then the AV updates would work after. I assumed your server was having issues. Something has changed in the Comodo system where we all–being computer literate–still are unable to fix the issue. I see that updating to the newer version did not help anyone on the forum.
Thank You,

Hello Laurianne. Your Comodo version is too old to receive av definition updates.

You will have to update to a newer version.

I have the latest version of CIS and yet my db won’t update. I see files downloading and progress bar and then it says that it failed to update virus signature db. Downloading a new db and updating it manually in windows safe mode every few days is a no go for me. Is it a known issue now? If not, how can I troubleshoot this issue? I’m on a 50 Mbps VDSL. CIS version is 4.1.150349.920 via autoupdate so the program updater works fine.

Hello Bucic. My first idea would be to try a clean install and then if the problem returns. If you are willing to do so then make sure you export the current active configuration (More → Manage My Configurations) and import it after installing.

Following is a guide on how to do a clean install.

Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run [url=]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.
C:\WINDOWS\system32\drivers\sfi.dat (this file belongs to stateful inspection of the AV )

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
fi. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
ji. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
ni. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
ri. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See:;msg119226#msg119226

How to uninstall the CIS firewall driver when it stays present after following this or using the clean up tool? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

Now reboot back into Windows and CIS should be gone and you should be able to install it again. You can run a couple of registry cleaners you trust to see if there any Comodo left overs.

Now you should be good to go

Thanks but no thanks :slight_smile:
I can do the manual update in 5 minutes and the reinstallation is a lot more. I’ve just swaped my cables to try the student hostel connection (behind a NAT) and it went with no problems. Does this give you any additional tracks which would indicate that clean reinstallation is not necessary?

Now we have to wait several days as the problem only happens once every few days.

In case it is the cable causing the problem then all other internet traffic would be impossible as well. Next time it happens try surfing the web to see if that works or not

I manually downloaded the latest bases.cav (87,569 KB), put it in the scanners dir, and rebooted. Still getting msg that it’s not the latest DB and clicking Update Now produces a bogus Internet connection problem error. I’m using version 4.1.150349.920, sig DB of 5238 on Windows XP. Thanks for any clues.

Web surfing works fine if that’s what you ask about.

Same here - also after manual update.