virtual memory too low

i installed csc 2 yesterday. today when i started the system it started too slow and finally a window appeared virtual memory too low. i did few reboots and tried increasing the pagefile but nothing solved the prob. then i uninstalled csc 2 and restarted the system and everything is back to normal.



Thank you for reporting this. Guys in QA will contact you on this. If you can, please let them look into it.


First of all, tell us exactly the version of CSC used on your system so we can start by running tests on that specific build.
You said that today your system started slow and that CSC was installed yesterday. Between these time periods, have you done some operations in CSC that worth mentioning? like performing a clean in some module(s) or using certain options. Please post the CRC, CDC and CPC logs here so we can analyze them (logs are found in Program Files\COMODO\COMODO System Cleaner).
Tell us the operating system in question.
And because the problem involves issues on low virtual memory, we could really use a list of other applications you have installed on your system.

Thank you for your support.

I have a bug like this also, when i startup my PC, after login service.exe goes to 2GB + of virtual Memory usage. (Without CSC install service.exe never starts up with the system)

Removing CSC fixes the problem, install CSC causes the problem.

CSC 2.0.107697.4
Windows XP Media Center SP3 32 bit.

Thanks, this slows down my system a ton, hope you guys can fix it fast.

I also had the same problem. I un-installed CSC V1 then downloaded and install CSC V2. I did not have a memory problem until I ran a registry cleaner. It identified 75 entries, I continued with the delete, creating a restore point and registry backup. The deletion completed successfully and I restarted my PC. After the re-boot, services.exe continued to eat memory. Over 1G before I decided to restart again. Same thing occurred after the second re-boot so I restored the registry from the CSC backup and performed another re-boot. And again services.exe eating away at memory. I then un-installed CSC V2 restarted my PC and everything is back to normal.
Windows XP media Center SP3
Security is CIS the latest

The page file usage problem should now be fixed. When you launch CSC again it should update for new changes to database and by doing that the problem should be gone.

Please tell us if the problem was solved.

Thank you for your support.

ok i m little late in replying as you guys have done some fixes. i will install and check again. then too the info you required are here

i installed csc latest version 2 but nothing further, i mean no cleanup nothing, just did some browsing and shutdown the pc. next day when i started the system the problem arised. rest you know.

genuine winxp sp3 with latest updates (its not a modified version)
the only security software installed is complete cis latest

again install and check as you guys have done some fixes and report here accordingly.


Edit by EricJH: edited the quotes

It worked here, ;D no more bug.

Thanks guys.

It did not work for me. I re-installed CSC V2 did the updates to V2.xxxxx.5 can’t remember the whole release but do remember it ended with a 5. It started sucking memory right from the start without even opening up the application. Went into task manager and services.exe was just eating away at memory. un-installed it and everything was normal.

Take a look into this post:
Lot of people experienced the same issue and CSC seems to be the cause.

I got the same issue with services.exe which is caused by CSC 2, uninstalling it completely solves the problem. In CSC I only use registry cleaner with no registry protection feature.
I had this issue in beta 1 as well, but I thought that it might be caused by bad installation or something like that. Now I see that lots of people have exactly the same issue with CSC. IMHO it should be added to known issues instead of saying it’s fixed. You may cripple some people systems or even cause them to lost some valuable data 88). Thankfully, it didn’t happen to me.

OS: Windows XP Pro SP3 + online updates
CSC 2.0.108716.5
CIS 3.11.108364.552

Stack of the thread causing problems in services.exe process.

ntkrnlpa.exe+0x6e9ab ntkrnlpa.exe+0x2bf82 ntkrnlpa.exe+0x2c864 [b]CFRPD.sys+0x4df4[/b] ntkrnlpa.exe+0x1819f ntkrnlpa.exe+0xa2ec1 ntkrnlpa.exe+0x6a62c ntdll.dll!KiFastSystemCallRet services.exe+0x9a15 services.exe+0x9833 services.exe+0x8e00 services.exe+0x8d22 services.exe+0x8b46 services.exe+0xd033 services.exe+0xc071 kernel32.dll!RegisterWaitForInputIdle+0x49

Is anyone going to take a look at this. I’m not the only one running into this problem and in my opinion it’s being ignored. Never had this problem running CSC V1. If not, there’s other free products out there that will do the same work. eg. ASC, CCleaner…

The problem regarding virtual memory is currently being analyzed. We will keep you updated.

Thank you for your support.

Thanks, i notice its back on my system.

I think it’s time I tacked my own entry here…
I’m experiencing some slowdowns with this installed as well.
My personal Vista machine is fine, but with the 2.0+ public release versions of CSC, my clients’ XP based computers have been experiencing the notorious services.exe loop (not so much with a recent update…but it seems it may have come back according to my customer).

May have the answer to your problem. I had the same problem so uninstalled CSC V2.0, restarted Win XP SP3 and services.exe was still going berserk. Tracked it down to the fact that CSC Uninstall had not removed CFRPD.sys from C:\WINDOWS\system32\drivers.

Manually deleted the file, restarted and all working hunky dory again.

Now running V2.0.110158.6 and this version looks to be okay

I have the same issue. Yesterday I updated Csc from version to version 2.0.110158.6 and services.exe starts eating ram.
I had to uninstall it to solve the issue.

It’s no longer forcing a services.exe 100% CPU loop, but it’s still munching down memory inexplicably.

Further to my previous post have found that CSC seems to react badly to the installation/update of other programs.

I had installed CSC 2.0.110158.6 and all looked ok even after a couple of restarts but then I updated a couple of programs and on the next restart services.exe was chewing up memory again.

Uninstalled CSC and made sure that CFRPD.sys was no longer in C:\WINDOWS\system32\drivers and then everything was back to normal.

Is one of the programs Perfect Disk?