Virtual Kiosk Not Loading

Greetings Forum Members,
any help would be highly appreciated.
I have attached the diagnostics report and the killswitch screenshot, but my guess they do not reflect my problem.
Comodo Virtual Kiosk has stopped loading. It starts loading, then freezes and even if I terminate the process via Task Manager, the loading window is still in the middle of my desktop.
I have Dell Inspiron, Win 7 64-bit.
I can still run virtual Ice Dragon and Dragon, but sandbox won’t load. Silverlight and Dragon were installed as recommended.
Resetting sandbox did not help.
I also have an issue with AVG and IObit uninstall and leftover files and drivers that I’ve been cleaning.
AvgIdx64 was a bad driver that caused boot up failure. I found it, renamed it to AvgIdx64.OLD. I also just uninstalled IObit safe protected folder. after that Sandbox stopped working.
This is way over my technical abilities. Will somebody help me? Please!

[attachment deleted by admin]

Uninstall and re-install did not help, either. :frowning:

Hi and welcome Vlasic,
Have you run the AVG cleanup utility found in the link below?
AVG Remover

Uninstallers (removal tools) for common antivirus software

Kind regards.

Oh yes, I did it BEFORE Kiosk crashed. I can still run browsers and skype in Sandbox, but I really miss Kiosk. What’s not funny - I cannot install Avg anymore. Comodo’s antivirus is paid, and having this Kiosk issue I am not sure if I won’t have any problems with Antivirus. Can there be a simple solution to this?

Please try this. Uninstall CIS and run all of the cleanup utilities I recommend in Safe Mode. My advice is here.

Once you have run all removal tools for CIS, run the same for any antivirus programs you used to have installed on your computer, but now have removed. Do this even if you have already run removal tools for them. I link to this in my other post.

After that restart the computer and install the newest version of CIS. See how that works. If it’s now working correctly let us know.


I did so. It was the first thing a person from Geek Buddy suggested, he gave me the link to Comodo uninstaller
I did the same for AVG, but not in Safe Mode. I anticipate it’s going to take someone like me two days.

Here is what I did, and so far I managed to launch Virtual Kiosk.
This is my thread on windows forum

As one reply suggested, I went to Autoruns for Windows - Sysinternals | Microsoft Learn
and ran Autoruns, screenshots attached.
I recklessly deleted 2 AVG and 2 Iobit leftovers that were in yellow.
I rebooted twice, so far so good. I tried starting Virtual Kiosk just in case, and it loaded. Somewhat slower than before, and I had to reset it, so now it works in the ‘tablet’ mode. I’ll see how it goes.

[attachment deleted by admin]