Virtual Kiosk locking...

Running CIS firewall and HIPs version 6.0.302093.2976

Hi, thought I’d sorted this after posting here…

No repeat of sandbox reset failing, but just had repeat of VK locking my system out at the ‘Virtual Kiosk is loading’ screen.

I updated AvastFree AV yesterday to version 2014.9.0.2013, so wondered if this might be a related cause. Turned off Avast and Virtual Kiosk opened fine. Repeated this three times to confirm Avast is conflicting with VK. VK stalls with Avast on but works with Avast off.

Added exclusion to Avast for CIS’s path…

C:\Program Files\COMODO\COMODO Internet Security*

No improvement. Can’t find any obvious mention of this issue on Avast forum so before posting there wondering if other CIS exclusions to add to Avast?

Hi, no suggestions either here or on the Avast forum. Fair enough. I can see from other threads that Virtual Kiosk is nothing if not interesting. :wink:

Found this old thread:

Reply #2850 by HeffeD…

"You can open the Kiosk without them from the CIS installation folder, and it will not require Dragon or Silverlight, but you are limited to classic mode and will not be able to use tablet mode. "

So I created a shortcut for virtkiosk.exe on my desktop and it worked! Avast Av no problem. :-\ repeated a few times and VK fine. It opens in tablet mode, mind, so not sure what difference it now makes running from the install folder.

Decided to have another go at the Comodo gui Virtual kiosk icon just to see. VK worked there too. :o No idea what’s going on with this VK app?

Just wondering… can I get the same security running a browser sandboxed along with osk.exe also sandboxed? Never believed the on-screen keyboard offered any protection, but would it do so running in a sandbox?

Can’t stand this hassle and got used to VK. :cry:

Okay… I’m updating this thread only in hope somebody might see a trend here. :frowning:

After last post VK kept crashing and locking my system, so I image-restored to before last CIS update. Everything worked fine with VK for a week…until I upgraded EMET 3.5 to 4.1. ??? That was the only change - which required .NET Framework 4 to be installed as well.

VK immediately went back to miscreant ways…freezing and locking my system. And the sandbox reset broke too. Even a reboot did no good. So I tried activating a different config, and that worked, for now.

My system’s clean: run all the normal scans and boot scans and CCC etc. So this is a process foul-up issue. I’ve turned off EMET 4.1’s certificate checking option as Comodo doesn’t seem to work comfortably with that either. EMET is only set to opt-in for DEP and I haven’t added CIS to it (Dragon needed all the ROP mitigations off). I know some of EMET’s mitigations mustn’t be used with sandbox apps, AVs and firewalls. So I haven’t added CIS and the system options are set as “recommended” … which is “Opt-In”… so far as I understand it EMET is leaving CIS and VK alone, isn’t it?

Something isn’t set right but I’m lost.

I’ll probably be back… :o

Only updating for the record. :slight_smile:

All previous amateur assumptions wrong, seems Virtual Kiosk needs specific allow path rule in SRP to virtkiosk.exe. Who knew? :o SRP’s default-deny already allows the program path etc, but maybe virtualisation fairies want more when running in standard account. Not EMET 4.1’s fault (though that caused other hassle until Dragon’s latest version 31.1 installed).

Sorry for cluttering the forum with my problems with Virtual Kiosk. :-\

Don’t worry about it. This forum is for users to get help when they have problems with Comodo products. :slight_smile:

Thanks for support. Using Comodo products for years and this forum only when self-help fails me… like to finish the story if I can in case it helps someone equally as baffled;D

I’m back. ;D

Today couldn’t get Virtual Kiosk to launch no matter what. Worked fine yesterday. When it crashes on take-off it really crashes. >:( Endless resets of system later, and tweaking anything in sight, noticed Avast’s fileshield was testing silverlight files at the time VK locked up. Uninstalled silverlight and ran VK. VK asked if I wanted full benefit and if so would need silverlight. Settled for just to see VK run and said no. VK came back on only without tablet mode. I’m running VK on a desktop so who cares. Three more lost hours just to get VK to work! Now have virtualkiosk.exe added to EMET4.1 and so far world’ s back to normal. :o

Was it the SRP rule? Maybe not? Was it EMET? Probably not. Maybe Silverlight was corrupting and crashing VK? Or maybe not… :-\

Quibble idk whats going on with COMODO’s software but I have the same problem win7 64x not sure what version u still have but ive tried them all like roll backing versions only to find that 6.0.x works without silver-light installed. Its not silver-light, not net frame work, not comodo dragon browser, it maybe 1 of the gazillion M$ updates but nothing points to a broken system on my pc. Fresh wipe,fresh install of win7 64x with SP1.

It feels as if there not interested in fixing VK and If this true ive used alternatives like virtualbox, virtualmachine ware before and java is the only thing i don’t have installed this time around and don’t see how that is related but the others required it to run this i do know.

Hi, beginning to think was alone with VK crashing. ;D

I’m on CFW version 6.3 ending in 2937 - ignoring nags to update further for now. I’ve had to leave off EMET’s cert pinning to keep Comodo Dragon sweet but I dare to think I’ve finally nailed VK down. It’s worked faultlessly for a week…was crashing OS every day before that :o

Was about to clean install Windows but decided first to create a fresh user account (couldn’t hurt). VK hasn’t crashed once since … still without silverlight. :slight_smile: My old ntuserdat file was a whole two meg bigger than the new account’s. That’s a helluva a lot of code sloshing around that I haven’t missed and apart from cheering VK by look of it, whole system seems like a fresh install. :slight_smile:

Process Monitor showed just how much VK does when launched so no surprise to me that when something breaks on its launch there’s a price.

Definately needed the SRP allow rule for virtkiosk.exe and the new user account hasn’t hurt. VK and CD are finally reliable, Still reluctant to update CIS again for a while. :frowning:

Interesting well im running the comodo internet security premium suite currently now 6.3.294583.2937 which has av&firewall together as well as VK and im still seeing problems with VK most likely phenomenal because after awhile of not launching itlike 12hrs or maybe a sequele of reboots as of yesterday for 1 time again out of the blue it launched 100% fine for once! Then i relaunch and reset VK and it jsut messed it all up again that easy. So still not stable in my opinion. What does EMET and SRP stand for? Something about certificates? I’d be welling to try your solution im not that good with abbreviations plz help me. :slight_smile:

Happy to say VK’s still giving me no problems after months of hassle. All the system resetting maybe mashed my user account and silverlight too. No idea, really, except VK’s now fixed. :smiley:

SRP is Software Restriction Policy, available on versions above Home Premium. Look for ‘Local Security Policy’ in administrative tools and run as admin. You can set up default-deny SRP rules which will lock out standard user privileges from running executables in strange places. Google it for more advice.

EMET is Microsoft’s ‘Enhanced Mitigation Experience Toolkit’ … an application to layer on more security. See here…

EMET needs a bit of fiddling too. Wouldn’t be fun if things worked first time :slight_smile: