Virtual Kiosk hangs on launch, after reset & clean re-install + DUMP [M277] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:Yes
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:I switch ON Virtual Kiosk and Kiosk not start. I wrote to this topic. My nick is radek178
  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?: I think no
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc: [Mod edit: User tried resetting, rebooting and resetting again, according to link].
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:6.0.264710.2708, Proactive

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:HIPS=OFF, BB=Fully virtualized, AV=ON, cloud=ON, FW=Custom
  • Have U made any other changes to the default config? (egs here.):Yes, Firewall>custom, (in Defense+>File Protection>3rd Party>third party I added \Device\KsecDD)
  • Have U updated (without uninstall) from a CIS 5?:No, I have clean install CIS 6, but I have upgraded w8 64b from w7 64b
    [li]if so, have U tried a a clean reinstall - if not please do?:I did clean install and reinstall many times but Kiosk still does not work, he is still launching, before when I switch OFF HIPS, Kios worked but not now
    [/li]- Have U imported a config from a previous version of CIS:no
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:windows 8 64b pro with WMC, account admin,UAC=ON, virtual machine - Vmware Player and earlier Virtualbox (I uninstalled now)
  • Other security/s’box software a) currently installed b) installed since OS: a=no b=no

[attachment deleted by admin]

Hi radek, thanks for your bug report

I’ve edited A.7 and B.7 if you would like to check them. Otherwise its fine.

Did you try removing your protected interface tweak and then rebooting?

If you check your computer for the hidden directory C:\VTroot is there any file in it? If so please take a copy of it, and record the path to it. Then try to delete it, when running as admin. Say if you cannot.

Best wishes


Hi mouse1,

I have no folder VTroot. Please have a look on the screen.

Sorry for my English, but I do not understand this sentence. What you mean?

Did you try removing your protected interface tweak and then rebooting?
Do you mean for example reset sandbox? If so, I reset sandbox very often.

I made short video. Kioks is still loading for example 15 minutes. - YouTube

I have VTroot only when I launch Kiosk and this folder cannot be copied when is Kiosk launching. But when I reset Kiosk VTroot is deleted.

I copied content VTroot. But I do not know if is there whole content.

[attachment deleted by admin]

\Device\KsecDD :slight_smile:

When looking for VTRoot, did you reveal hidden files?

Best wishes


I have \Device\KsecDD on another PC and Kiosk work good. But I can try delete it.

Yes, I have hidden files switch ON. VTroot is deleted when I click RESET KIOSK.

But I tried launch Kiosk on anther PC and it does not work too. Probably after upgrade to version .2708

Thanks I’ll forward this now.

There is another file called fvstore.dat that an be deleted, if it has not been. Not sure re location.

May need to delete in safe mode

Best wishes


Where is the file fvstore.dat?

Wierdly C:\Windows\System32\drivers!

I have no such file in this folder C:\Windows\System32\Drivers

The file ‘fvstore.dat’ is only created after running Kiosk and re-booting the system without resetting the sandbox.
This file is removed on resetting sandbox on my system.
More information here about that file.

Ok, I will try it. But I must reboot PC when I launching Kiosk because when I launch Kiosk he not started and only loading and loading and loading and I cannot switch OFF.

I found this file after reboot PC.

[attachment deleted by admin]

I am not sure if it will help your issue.
I was mainly pointing out why the file was absent on some systems.

Ok, thank you for your help.

  1. Have you tried the hard uninstaller tool: Comodo Forum

  2. Was CIS 6.0 or 5.x (specify which please) installed when you upgraded to Win 8?

Pondering this, your best chance of a fix is to take a full dump of both virtkiosk.exe instances when Kiosk is hanging. It’s just a right click in Killswitch - files are big though so zip and upload to the cloud and post a link.

I’m guessing the devs may be grateful if you do, as Kiosk hanging has been a fairly persistent problem

Best wishes


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


yes, I had version 5 on both PCs. I install and uninstall Comodo several times.

I will try it. I hope that I make it. I am must improve my English.

I created dump both files virtkiosk.exe.

Link is here Box

Well done! That should be a big help to the devs.