Virtual Kiosk does not show the language bar of the "ctfmon.exe" [M281] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:Yes, reliable
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    Please see the attached screenshots.
    (1) From the ci70.png, the ctfmon.exe shows a language bar.

(2) From the ci71.png, the ctfmon.exe does not show a language bar.

(3) So, the user can not change the input method in Virtual Kiosk.

(4) The same result is for Virtualized Browsers.

(5) Please show the language bar (virtualized) when using VK or VB.

  • If not obvious, what U expected to happen:
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)ci74.png

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:CIS 6.0 Build 2708, Internet

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All, HIPS=off, BBlocker=Partially limited, Firewall=Safe, AV=cloud is on
  • Have U made any other changes to the default config? (egs here.): no
  • Have U updated (without uninstall) from a CIS 5?:no
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:no
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows XP Pro, SP3, 32bit, UAC=off, admin, VM not used
  • Other security/s’box software a) currently installed b) installed since OS: a= b=

[attachment deleted by admin]

Thank you very much for your bug report in standard format. We very much appreciate the effort you have made to document this bug.

We are sorry to trouble you further but there are some items of information missing or unclear in your post:

A.8 Your Watch Activity Process list
B. 6 You user account control setting
I have also edited B.1, and B.2 please check that my edit is OK

The reasons we need these items of information, though they may not seem directly relevant to the issue are explained here.

We would be very grateful if you would add these items of information so we can forward this post to the format verified board, where it is more likely to get fixed. You can find assistance using red links in the Format and here. If you need further help please ask a mod. If you do not add the information after a week we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report which includes all necessary information or not. We may remind you if we think a bug of particular importance.

Many thanks again


PM sent

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

a256886572008 is this problem fixed in CIS v6.1?

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

XP Pro SP3 32bit

  1. VK does not show the language bar.

  2. I can not switch the input method by the hot keys.
    “Ctrl + Shift”

(1) I switch to the input method of Microsoft by the hot keys.
For example, “Ctrl + Shift + 0”

(2) After doing it, I can switch any input method by the hot keys.
“Ctrl + Shift”

Please let VK show the language bar so that users can easily switch the input method by the mouse cursor.

Okay, if you’re okay with it I will consider this to be fixed and move it to Resolved.

Thank you.