Virtual Kiosk / Desktop won't run

I am running Comodo Internet Security Permium 11. I can’t start Virtual Kiosk anymore. It used to work a month ago, but doesn’t now. When I double-click on the Virtual Kiosk icon, I see an hour glass symbol for a short time, then it goes away. Watching in Task Manager, I see that the attempt to start Virtual Kiosk causes the “Virtual Service Manager” to start. Nothing else happens. The same thing occurs when I click on “Run Virtual Desktop” in the Comodo Containment Tasks window.

I am running 64 bit Windows 10. The most recent update installed is version 1803.

I un-installed CIS completely and did a clean re-install. After that I was able to start Virtual Kiosk ONCE, but once in, nothing would run. The classic desktop was blank. I tried to start Comodo Dragon and was told that it couldn’t find the program. The path in the error statement pointed to the correct location for Comodo Dragon. So I closed Virtual Kiosk. After this one “success” I was back to the behaviour described above - nothing happens.

I tried Resetting the Container several times - no improvement.

Any thoughts?

Perhaps this may help:
open cis
go to task (on the top left corner)
click on down left side Unblock Applications
look for comodo\virtkiosk.exe and set a hook in the little box
go to Unblock (on the top left) and unblock virtkiosk.exe

Go to "C:\Program Files\COMODO\COMODO Internet Security" and run “virtkiosk.exe” as administrator. Does it launch? If so might be some privilegies problems.

OK, I tried both suggestions:

The Block List is empty (probably due to my recent uninstall/reinstall), so there is nothing to unblock.

Running Virtual Kiosk as administrator didn’t change anything - still won’t start.

Try to allow vdcss.exe in firewall and/or HIPS!

Open settings/Firewall/Application Rules/Add/Browse (on top on the right corner)/running processes (maybe the last point) click on, choose 'Use a Custom Ruleset/Copy from" and allow and do the same in HIPS if enabled.

You can use virtual desktop, but that’s not what you want! It needs silverlight!?

This might be true.
In the case of mine, silverlight installed on my system, but virtual desktop keep report that I didn’t install silverlight. odd.

I don’t find vdcss.exe anywhere on my PC, either in running processes or on my C: drive. And silverlight IS installed.

When I click on either the IE icon or the Dragon icon in the Comodo widget to run them in the container I get an error statement that Windows cannot find the program. The paths shown in the error statement is correct.

I would suggest completely uninstalling CIS with the Comodo Uninstaller and also uninstalling CSS and Dragon (through Control Panel)

Then do a clean install, taking all the Component options of Dragon and CSS - then try again

Here’s one for you. I searched for the Comodo Uninstaller and downloaded the CIS/CAVS/CES cleanup tool for x64 from the Comodo site and ran it. Just after it said it was creating a Restore Point, my PC crashed to a blue screen. I had to manually reboot.

After reboot, I was surprised when the CIS widget still appeared on my desktop. Just for grins I tried to open Dragon in a container - it worked. Virtual Desktop also runs now. I rebooted again, just to be sure and things still work!

I have no idea what happened or what the cleanup tool did, but I’m pleasantly surprised at the outcome.

If this is permanent then I consider my problem solved. :-TU

The problem is that nobody knows what you do and did. It’s often difficult for oneself to know what you did. I.e. to use registry cleaner, pc-tools/tweak which all can irritate your OS a.s.o. and destroy your registry.

If one wants, is it still safe using virtual desktop (not secure shopping) with silverlight, or is it dangerous?

Well, we’re back to where we started - no virtual desktop. Didn’t work this morning, so I went through the whole uninstall process with control panel and then used Comodo’s uninstaller. (At least that ran correctly this time.) After several reboots, everything looked clean, so I reinstalled CIS and Dragon.

Virtual desktop ran once, normally, but never again.

Since the main reason I use CIS is to have the virtual desktop, I will remove CIS and change to a different security product.

Thanks to those who tried to help. I think this is a lost cause.

That’s what I meant. Nobody knows what you really did and as for me, too, sometimes you don’t even know what you’ve done.

I uninstall with RevoUninstaller which finds all remnants of a program to uninstall.

Both ‘Secure Shopping’ and 'Virtual Desktop" run without problems on my PC. I only don’t know if it is safe to use Virtual Desktop with Silverlight (which is no longer maintained by microsoft and and should therefore be a danger or a target for attacks, to my knowledge). I like ‘Virtual Desktop’ .

I’ve read you can use Silverlight together with a safe program.