Virtual Desktop Not Opening

Virtual Desktop will load but won’t opening. How do I fix this?

Hi Protected PC,

Can you please share Windows OS and CIS version you are using, as we don’t have any issue here.

Kind Regards,
PremJK

Works fine on Win10 Pro 64 here also

CIS Version: 10.0.2.6408

Windows 10 Pro Version: 1709

How quickly we forget…
Windows version build numbers are required. 1709 is meaningless…
I’m running build 17035, also listed as Windows version 1709. I’m on the fast ring, as are many others.
If you cannot provide a build number, your report is as useless as not including a CIS version number!!

Am I clear, everyone???

Sorry, I got it.

Windows Build: 16299.64

CIS Version: 10.0.2.6408

Hi, Protected_PC.

Please try to delete virtkiosk.exe from “%programfiles%\Comodo\Comodo Internet Security” folder, perform ‘Update’ via CIS UI and reboot after that.
Check the issue again. Let us know the results, please.

Kind Regards,
Sergey.

Crystal!

I tried that & it’s still not working.

Here a image of what’s going on. It won’t execute.

I would perform a clean uninstall and install again, also make sure other security software is not installed that could be interfering with CIS. I too have no issue opening virutal desktop with the same Windows and CIS version.

It’s working now, I wonder what could have caused it to not work though.

Hi,

I had the same problem and was about to reinstall Comodo in order to fix the issue, but I was able to track down the culprit.

It turned out that the drivers installed by pCloud related to Callback technologies prevented the Comodo Virtual Manager from opening. When uninstalled (manually from the Control Panel, using Autoruns, Device Manager, Windows Search etc.) Comodo Virtual Manager is now working as it should. Can you confirm that please because I don’t believe this was a coincidence?

R3 vpnpbus; C:\WINDOWS\System32\drivers\vpnpbus.sys [20568 2018-03-29] (Microsoft Windows Hardware Compatibility Publisher → Callback Technologies, Inc.)
R1 cbfsconnect2017; C:\WINDOWS\system32\drivers\cbfsconnect2017.sys [475224 2018-03-29] (Microsoft Windows Hardware Compatibility Publisher → Callback Technologies, Inc.)

Thanks!

Hi. I know it’s an old thread, but I have the same issue here.
Windows 10 20H2, 19042.928
Comodo 12.2.2.8012.

Same issue with previous versions. Any ideas? I haven’t installed any pcloud software.
Thanks

Some things you can do:

  1. Check for memory dumps in C:\ProgramData\Comodo\CisDumps
  2. Check the HIPS logs for any blocked events.
  3. Make sure you are not using other 3rd party security software.
  4. Do you have memory integrity core isolation enabled? If so try disabling it, reboot, and try virtual desktop again.
  5. From an administrator command/powershell prompt run fltmc and provide the output.

Is it just the virtual desktop that won’t load? or does all other uses of containment not work either? Such as right-click on an application and select run in containment, launching a web browser from the CIS widget, or running an unknown application that would match an auto-containment rule.

Thanks fpr the reply!
Disabled HIPS - no change in behaviour (diabled logging for the time being)
No other 3rd party security software isntalled.
Memory integrity core isolation disabled
No CIS dumps found in C:\ProgramData\Comodo\CisDumps
when i did fltmc i recognized it still mentiones sandboxie - can this be the issue (and a 3rd party securit software :-))?
Filter Name Num Instances Altitude Frame


bindflt 1 409800 0
cmdGuard 5 321200 0
storqosflt 0 244000 0
wcifs 0 189900 0
CldFlt 1 180451 0
FileCrypt 0 141100 0
luafv 1 135000 0
SbieDrv 5 86900 0
npsvctrig 1 46000 0
Wof 3 40700 0
FileInfo 5 40500 0

THANKS for the effort!


Update: uninstalled Sandboxie - no change
Launching a web browser from the CIS widget works - it’s just virtual desktop not working here :frowning:

I have no idea why it doesn’t work, however you should run cisreporttool and provide the zip archive it creates, you can download it from here http://download.comodo.com/cis/download/installs/cisreporttool/cisreporttool.exe

Comodo will investigate and maybe they can figure out what is wrong. I will contact one of the staff members to let them know of the issue.

Hi ChickenNinja,

Thank you for reporting, we will reach you through Private message to get required information