"Virtual Desktop" causes lock up if "Emsisoft Anti-Malware" is installed [M1377]

every time I try to run to Comodo Dragon or Google Chrome fully virtualized my computer always locks up and I have to forcefully restart it with the power button its REALLY annoying. it was working fine a week ago I had V7 and yesterday I upgraded to V8 and yes I did a full uninstall and installed V8.

Im running Win 7 64-Bit

In order to further process your bug report you have to use the required format.

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes. Every time.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Download & Install Emsisoft Anti-Malware v9.0.0.4668.
Link : Download F-Secure SAFE 2018 for Windows - Filehippo.com
2: Restart computer system.
3: Run “Virtual Desktop”.

One or two sentences explaining what actually happened:
You will notice a conflict which translates in freeze.

One or two sentences explaining what you expected to happen:
There should be no freeze, as in past versions (v6, v7).

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:
Emsisoft Anti-Malware

Any other information, eg your guess at the cause, how you tried to fix it etc:

  1. I’ve tried reinstallation. The issue persists.
  2. While everything is frozen, I can only reset my computer system in order to avoid it.
  3. This issue can be replicated trough various ways as long as these imply “Virtual Desktop” module. As for example, launch a browser in fully virtualized mode.

Exact CIS version & configuration:
V8.0.0.4337 | Configuration : “Firewall Security”

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Have you made any other changes to the default config? (egs here.)

Have you updated (without uninstall) from CIS 5 or CIS6?:
if so, have you tried a a a clean reinstall - if not please do?:

Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
OS : Windows 7 Home Premium 64-bit | UAC : Default | Account Type: Administrator

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

I also ran the Virtual Kiosk just to verify and the same thing happens as the browsers, computer just locks up then when I go to reset the sandbox the only process that is still active is the cmdvirth.exe

I have reproduced this issue on my virtual machine. It seems like there is a conflict between Virtual Desktop & Emsisoft Anti-Malware v9.0.0.4668 which causes the freeze.

I’ve made some edits. Do these modifications reflect your bug report?

Thank you.

I already have V9.0.0.4668 of Emsisoft Anti-Malware Installed Ill uninstall it then run the browsers in the sandbox again if they work like intended I can easily ditch Emsisoft and get with Avast Antivirus and Keep Comodo Firewall obviously :slight_smile: thanks for your help Ill see what happens be back in a bit with the results.

Thanks. I will wait for your reply.

yup just as you said the current version of Emsisoft Anti-Malware Version BREAKS the fully virtualized Comodo sandbox when running the browsers or Virtual Desktop.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Reproducible on my virtual machine with version <>. I’ve updated tracker data.

Thank you.


The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

Should be fixed with CIS so moving to resolved. If you feel that this is not fixed please PM a moderator. Thanks.