Very poor performance - PC unusable during DB updates

I like CIS otherwise, however durng database updates, the host PC becomes unusable. Is there a fix for this???

The host PC is an older tablet PC running XP w/ SP2, w/ 1 GB RAM, and a 1.8 GHz Pentium M. NOt exactly a supercomputer, but still:
a) the system runs fine otherwise, and
b) to consumer 100% of the CPU during updates, and not allow other processes to run is not acceptable.

Can CIS be set to run at a lower priority during updates? Is there some other work around for this?


Does this happen on every update or only the initial ones?

Comodo Offline Updater for CIS has been released which means you can stagger updates etc…

see here;

Seems like every update. Thanks - I’ll check out the ‘offline updater’, and see if that helps.

Thanks for the suggestion…

There is currently no workaround. This issue has been known for a long time and reported frequently. To my knowledge, the devs have never even commented on it…

I don’t think it can be fixed without some substantial code rewrites, but why they don’t release a band-aid fix like lowering the process priority I couldn’t say.

And to answer Erics question from my experience, this happens with every reboot. Regardless of how soon it has last updated, shortly after the OS loads, I am locked out of my machine for 5-10 minutes while the database updates. I never had this problem before installing version 3.12.

XP Pro SP2
AMD Athlon 64 X2 Dual Core 4200+, 2.2GHz
220+ GB free HD space

The offline updater isn’t very practical for home use…

Can you advise what other security programs are you using?

Can you check that windows firewall is disabled?

I’ve not experienced this issue myself.

In my case at least, Windows Firewall is off, and I am not using other security programs. Specifically, I have (previously) run an ‘uninstall’ on all other security programs.

Could there be a left over process from other tools that I tried? - I suppose that I can’t rule it out… I haven’t detected it, or noticed an impact at any other time.

I think there is left over stuff, usually in the registry that causes problems like this. Try running CCleaner, clean the files and them also clean using the registry cleaner. IF that does not work we can go to more powerful registry cleaners.

I also use A2 free, Avira (free), Malwarebytes, and SuperAntiSpyware. These are on demand only. CIS is the only real-time security application.

I also run Secunia PSI, although that’s not really a security application.

Regardless, I’ve run these the entire time I’ve had CIS on my machine (Just after 3.5 was released) and the problem didn’t show up until the 3.12 release.


You’re lucky. I was also lucky up until I installed 3.12. Now I’m unlucky…

I’m really starting to get discouraged that this is apparently a non-issue to the devs. It only started impacting me recently, but some have been dealing with this for a very long time and they can’t be bothered to even acknowledge there is a problem. It’s such an annoyance to me that I’m on the verge of looking elsewhere for my systems security.

My system:
XP Pro SP3
Intel E7300 Dual Core
4GB RAM (only 3GB under XP)
640 GB HD

I don’t get lock-ups but I noticed that when I start system I get high cpu load from cmdagent.exe (DB update I guess) and also when new DB is updated there is high (over 80%) cpu usage as well. I can work on the computer though. So it doesn’t cause me any trouble but the cpu usage on my dual core machine is fairly high. I only guessing what updating DB can do on slower systems.

Well I’ll be darned…

Whether it is because subsequent updates are much quicker, or there is actually some link between the registry and performance of CIS during updates, the issue seems much improved on my system. Interesting!


i suffer of the same problem and my new quadcore has HD spinning all the time for a couple of minutes freezing up any other activity.
This happens only in my home pc and not in the twin that i have in office; only difference is that in the office i suffered of 100% cpu damned update problem weeks ago, that forced me to proceed in rebuild a new database following your advices to solve the problem.
Maybe this could be an hint to solve this problem too.

Last time, i have logged with PROCMON all the boot and after-boot activities (approx 10 min.) and that’s the results:
BASES.CAV has been used approx 15% of the disk activities (consider that i have opened browser and done some more activities in that time)

BASES.CAV total events are 3522, 19 times open and 19 closed, 3324 reads and 88 writes
read bytes were 108.908.611,
wroted bytes were 435.798.738 really a huge quantity = 60% of disk activity in that period
99% of comodo activities were on this file

Hope this help
Problem is really annoyng

Are all of these reads just during an update? If so, that seems odd… However, if that number is for an extended duration, that number seems fine. Since it needs to do a lookup whenever you open a file, (unless the stateful flag is set) I don’t think it would take long to get 3,000+ reads.

Edit: re-reading your post you mention this was approx. 10 minutes. I still think that number of reads is entirely plausible in this length of time, especially as you are browsing the internet, as each page you visit could generate dozens of new temp files. Each of these would need to be scanned, chalking up another lookup in the bases.cav.

again i made a more clean test, i mean just opening the PC and waiting for 10 minutes while procmon has monitored all activities. I repeat no other activities has been done.
In that period Comodo has made his DB update.

Report on file activities is the following:

  • Comodo has made 3190 READS and 440 WRITES on bases.cav
  • 104.529.770 bytes has been read of the same file
  • 2.091.857.349 bites has been wroted (42% of whole writing activities)

My first thought is why Comodo during updates writes 2.091.857.349 bytes when my bases.cav is 102.000 KB; second why during this activity that take between 1 and 2 minutes, computer is totally frozen.

Second thought: it happens only on my home pc that normally i open 1 time per day, in that period Comodo made a whole update collecting probably many different updates of the previous 24 hours; it never happened on my office pc that’s open 12-14 hours per day and in that period he made many singles updates.
Therefore the problem seems to be related to the number of updates received.

These are my 2 cents on problem.
Hope this help.


For f*ck sake >:( Will anybody from Comodo team address this issue?
My PC was frozen for 2minutes today (immediately after OS started) during a DB update.

My system:
XP Pro SP3 (Czech)
Intel E7300 Dual Core
4GB RAM (only 3GB under XP)
640 GB HD

CIS version 3.13.121240.574
DB version 3287

I believe we’re just going to have to wait and see what version 4.0 has in store for us. Hopefully they use a smarter updating procedure.

I have been using Comodo for a couple of years and i have liked it and stayed with it during good times and bad. But, I am just about ready to uninstall CIS. The “sloooooow” performance hit when AV module is updating, bootups, and shutdowns in the last few months makes my laptop just about unusable not to mention blood preassure…It’s getting to the point where CIS is affecting my system performance nearly as bad as malware would. Don’t get me wrong CIS is a great product, but if you can’t use your computer what is the point of having it. I may stay with it until V4 to see if it is better…but if it isn’t I have to move on…life is just too short.

I suffered from the exact same problem you did and have a similar setup, except not a dual core. I have all workarounds enabled that have been mention including the DEP fix.

Yet every boot resulted in 5-10 minutes of lockup. Then every update would cause a lockup for 2-4 minutes. There have been plenty of posts about the freezes.

Remember the old adage: for every person that complains, there are 10 more that don’t! How many folks are suffering thru this?!

I finally dumped Comodo and am trying ZoneAlarm again. So far so good and while not free, it is currently on sale and covers 3 PCs for the price.

Hello everyone.

FWIW, I started this thread (although it sounds like I’m not the first to see this problem).

  1. FYI, as strange as it sounds, the fix suggested previously of running CCleaner fixed this problem on the computer that I was having the problem with. I know, I thought my reg was clean, but I tried it anyway, it helped a lot. (I was very surprised).

If you are having lots of problems, if I may suggest, this fix(?) could be worth a try. Doesn’t cost much (just a little time…)

  1. Also, this problem doesn’t seem to show up on every computer on which CIS is installed. For example, I just installed it on my GF’s (new) netbook. While the installation didn’t complete the first time, once I did get it installed, performance during updates is OK - on a NETBOOK.

It seems as though at least in some cases, CIS works OK.

I hope this info helps… good luck!

I use CCleaner. It hasn’t helped me. Like I said, I only started experiencing this issue with the 3.12 release, so some change Comodo made caused the problem on my machine.

Ah well, it was/is worth a try, but you’ve already done that…

It’s interesting (imho) that the problem only affects some machines. Not sure what (else) could be up with that - guess we’ll have to wait for the folks at Comodo to shed more light on that.

Fyi (again for what it’s worth), I’m running version 3.13.

Good luck!