Version 3 is really scaring me!

OK, maybe someone can tell me how all this was NOT Comodo. It really doesn’t sound like it should be.

I was concerned about it possibly slowing down my internet access, and decided to turn it off, just for a bit to see. But then when I tried to open Mozilla, I got a system message saying it was in invalid application! Thinking that maybe some disk corruption had occured, I tried to open Computer Management to so I could do disk check on the boot drive, but then got a message that compmgmt.msc was invalid. WOW! So then I paniced and rebooted. Turned Comodo off again, and got the same problems. EEEK! Then I restarted Comodo, and all these applications suddenly started working. Mail, computer management, etc.

So now I feel like I can’t run normal applications unless Comodo is on. I am getting scared about what would happen if I try to uninstall it.

The bottom line is that I should be able to turn it off and the only downside will be increased security threats, right? I mean, it shouldn’t be disabling my system applications should it?

Sorry, I have to say I am also scared!

I tried to upgrade at your insistance the v3. I accepted all the logical luggestion until I could go no further. I found the my email was not working, I tried accepting the email option but no go…several times and still no email.

I have reverted to yesterday (XPPro SP2) and all is now fine.

I shall have to refuse the upgrade (which I realise is a ‘GOOD THING’) until I can be sure of avoiding this hassle!


Oh guys I agree with you about this.

I got blue death screen in Windows XP for several times. Pls fix it first before u release something, I did not know that the product is so unstable! This version keeps popping up messages all the time, it is very annoying (although it can be turned off in the settings).

Otherwise good job in providing such a reliable solution to people for free. For now I will switch back to CFP 2.x as it was running smoothly all the time. This new one also uses more system resources and it slows down the PC during start.

Please, make a distinction between usability and firewall quality. People want simple & stupid things. As a psychologist I find it unnecessary to be so annoying in popping up messages all the time like that (“Firewall is learning…”). The menu is also not as clear - before the option to “block all, allow all and custom” were really useful sometimes. Now you can get lost in the settings.

Also I got messages (every 30mins) with “Ooops, you just discovered a bug, the application has to be closed”. However even after that, CFP does not close, it remains running like nothing happened. It seems to be very firmly attached to the system and it has more power over everything than any other application apart from Windows itself. How far do you want to got with that?

Today when I booted up, I still had Comodo enabled to start at boot-up. Just after the boot-up, I noticed that I had NO system tray icons, except for Comodo. This is the first time I can recall this happening ever. There are usually 2-3 of these guys. ASUS control panel, volume control, printer status, etc.

I the went into Comodo and set it so that it would NOT start at boot-up (and BTW, am very glad that you have that option so easily accessible), then rebooted. The system tray icons showed up, but then when I tried to media jukebox, the system said there was no such application! So I started up Comodo again, which allowed me to start media jukebox. I then rebooted and Comodo did NOT start as I wished, but media jukebox worked.

So it really appears that this version of Comodo will prevent us from running our own applications directly on our computer. I just didn’t see any warning about stuff like this.

If you can tell how to get back to the previous version without problems, that would be great!


Try Opening and select “Firewall” - “common tasks” - “Select” “File Groups” " “Start up folders”. This seems to smooth out some of these initial install issues V#.0 has with existing programs. (:NRD)

OK. I have WindowsXP and I don’t seem to have anything called “common tasks” under firewall controls.

But I have found a workaround. When Comodo is running, go to the Defense+ settings and set it to “disabled” (I had it on “Clean PC” mode before). THEN you can turn it off and all your applications should work. Comodo should enable everything when it shuts down, but it doesn’t.

Agreed bobby. Turning of Defense+ will solve invalid app problem. Why comodo does this tho? well, we shall wait and see what they say. But I happily, forget the happily. Im rather annoyed, but anyways, I run the firewall without Defense+ and am going to continue to do so till they promise me its fixed.

Right here, Common Tasks (on the far left):

…but - “Select” “File Groups” " “Start up folders” ???