Vanishing File Groups Part 2 [NBZ]

1. What you did:

I changed the name of a file group in the File Groups window.

2. What actually happened or you actually saw:

The name changed just fine. However, when I went back to my Defense+ Rules, where the group was once showing, it is now gone.

The file group is also part of my Firewall Rules, and oddly shows correctly there, with the new name.

3. What you expected to happen or see:

I expected to see the group with the new name in my Defense+ Rules.

4. How you tried to fix it & what happened:

No fix. Just have to re-add the group, under its new name, to my Defense+ Rules.

5. If its an application compatibility problem have you tried the application fixes?:

Doubt it.

6. Details (exact version) of any application involved with download link:

CIS 5.0.162636.1135

7. Whether you can make the problem happen again, and if so exact steps to make it happen:

Happens every time. Make sure you the group is present in Defense+ Rules. Change the name of the group in the File Groups window. Go back to Defense+ Rules and observe the magic.

8. Any other information (eg your guess regarding the cause, with reasons):


1. Screenshots illustrating the bug:

How should I illustrate this? Before & after?

2. Screenshots of related CIS event logs and the Defense+ Active Processes List:

Not Applicable?

3. A CIS config report or file.

Not Applicable?

4. Crash or freeze dump file:

Not Applicable?

1. CIS version, AV database version & configuration used:

CIS 5.0.162636.1135
AV 6778

2. a) Have you updated (without uninstall) from CIS 3 or 4:
b) if so, have you tried reinstalling (if not please do)?:

Fresh install of CIS5. No Previous versions.

3. a) Have you imported a config from a previous version of CIS:
b) if so, have U tried a preset config (if not please do)?:

Fresh configuration.

4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. )

The file groups are all my own, if that matters.

5. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =

Seems to happen regardless of these.

6. OS version, service pack, no of bits, UAC setting, & account type:

Windows 7
Administrator Account (sort of)

7. Other security and utility software installed:


8. Virtual machine used (Please do NOT use Virtual box):


Thank you for your bug report in standard format.

Moved to verified.

Thank you