v3 doesn't pass GRC LeakTest [Merged Threads]

Should I be worried. The firewall passes GRC Sheilds Up Test. 100%.
Why does it not pass the other test?

Welcome to the forum.
CFP Pass their leaktest with default (auto) install, so you don’t have to worry.
If you get popups from CFP about their leaktest when you run it, you must block the connection. That’s what it’s all about.
Remember to reboot when you have tried any leaktest.

Welcome to the forum!
I don’t think that the CFP failed - you did ;D.

Let me guess: you started the Leak test, and clicked on test button. Then you received a popup from CFP, and you clicked “Allow”. That’s what you did wrong. You should have clicked “Deny”, since this is an unknow application trying to connect…

Edit: Oops, i guess AOwL already answered while I was typing ;D

It’s better to have two answers than none… ;D

Indeed. Especially if they are basically the same - that means they are correct. :smiley:

I allowed leaktest to download to my computer (and probably remembered the answer) but when running the test itself, Comodo failed. I’ve tried everything to no allow leaktest but it penetrates every time.

So… what next?

By choosing “Block this request” in the firewall alert, you should make the test without Defense+ enabled. You shouldn’t have to do anything else.

Cheers,
Ragwing

same here. even in Paranoid mode the leak test goes through.

I disabled Defender + and blocked all with FP, and as far as I can tell purged leaktest.exe for the firewall and it still didn’t pass GRC leak test. It did however pass the CPIL test. ???

I passed the leak test with 3.0.13.268

If your computer is currently connected to the Internet, the most likely cause for LeakTest’s inability to
connect is an aggressive and properly working firewall. If so, it is preventing LeakTest from connecting to our web server’s port number 80 (HTTP).

  1. Download LEAKTEST.EXE from grc.com
  2. Double click LEAKTESTs icon to start it (if prompted when trying to start leaktest.exe, select ALLOW)
  3. When LEAKTESTs GUI oens click the “Test for Leaks” button
  4. You should immediately get a prompt asking if LEAKTEST.EXE can access the internet. You should select BLOCK.

If you did not get a prompt at step 4 than I would suggest that you have click ALLOW at some point. Check through your application rules and delete anything related to LEAKTEST.EXE and try again.

Ewen :slight_smile:

P.S. The above procedure works with the “out of the box settings”. I didn’t have to tweak anything or create custom rules to get this to work.

Works exactly like that for me as well. I did notice though that if Leak test is already on your computer when you installed CFP-3 that it will be listed as a safe app and you will not pass.

John

Comodo passed leaktest, but changing Comodo’s rules didn’t work for me.
I have a new thread for this issue already:
https://forums.comodo.com/help_for_v3/changing_an_applications_access_rule-t15495.0.html

Well, I’ve tried everything. V3 does not pass the GRC leaktest, which is to say FP is being penetrated.

Note. Dont take the test with BOClean enabled. It tags it as malware.

I was curious about all this Leaktest issue, and downloaded the program. Like the mods have said, I only had to block connection once I got the alert, and I passed the test. So, in my case CFv3 did work.

Well, I don’t know what to say. According to leak test my FP is being penetrated. >:(

The Leak-Test doesn’t function properly with comodo 3.0 installed. Comodo detects that the heuristics has found malware-like behaviour and pops up the standard window from which you can choose your actions (Block) :slight_smile: .

Greetings :slight_smile:

OK, I’m imagining things… no pop up nothing.

[attachment deleted by admin]

Do you all have 3.0.13.268 installed? If not - run the updater :slight_smile: