V3 and Webroot Spy Sweeper Problems [Merged Threads]

V3 is blocking the email scanning in Spy Sweeper. I am unable to receive any of my email. How do I set this up to get it?

Have you tried setting SpySweeper to a Trusted Application?


yes did that- do i need to set up the email port somewhere in V3 or something?

Probably wouldn’ hurt to add some rules for your email ports to see if that is the cause or not.

It depends on where you get your email from but generally an ISP email account will use ports 25 and 110. These are both TCP- OUT.

Gmail uses ports 465 and 995 and 587(SSL, I think) and these are TCP.

If you don’t know what the IP addresse or hostname of your mail server is then you can just use “ANY” as the destination until you can find out what the IP or hostname is. Probably could call your ISP to get that info.

If you need help writing the rules just say so and we will be glad to help you.


Just installed v3 today. Whole system is totally slowed down. Can’t open Firefox. Uninstalled Webroot Spy Sweeper and Comodo Firewall v3. Reinstalled each. Computer runs normally when each is installed individually, but if I have them both installed, everything slows down or jams up. Firefox won’t open, can’t close or open other software without everything freezing up. I have Windows xp. Right now I have just Spy Sweeper installed and all is well. What the heck??? (:AGY) I want my old version back.

I used to have SpySweeper and it goes deep into the OS which is what Defense+ does also. I know that SS is not classified as a HIPS technically but some parts of it take over a system.

Do you have any other security software or out of the norm software installed? Any info you could give helps the dev people to isolate the glitch and get it fixed.

Thanks for your help,


Oh, I do have Vista Inspirat 2 Bricopack installed on Windows XP. Could this be the problem? I can’t figure out why I can have Spy Sweeper or Comodo Firewall v3 installed, but not both of them together without serious slowing or not responding issues. ???


Bricopack seems to be an issue… pls read above…


I have AVG Free Edition, Lavasoft Ad Aware…that’s about it.

Hi Saturk - have you managed to resolve this? I too am having problems getting Spysweeper’s Email Attachement to work with v3 - and was worndering what you did to get yours to work.

I also am having trouble getting email. With Spysweeper and CFW3 both running, always get an error and no email. The (bad) solution is to shut down Spysweeper.

I have added all executables for Spysweeper as Trusted Applications, and have done the recommended “Temp Fix” shown in this forum. None of that helps. The only way to get email is to shut down Spysweeper.

I, for one, would like detailed instruction on how to set up ports manually (I am NOT a tekkie).

Opps (blush)…

I should have added in my last post that there is nothing exotic (gmail, hotmail etc) about my email. It comes via ISP such as Comcast broadband cable

The rules alone might not make any difference but here are the rules to try. I have seen a lot of conflicts with Webroot so far and I’m sure the devs have seen this also and are working on a fix.

Most normal ISP’s email servers will use ports 25(smtp) and 110(pop3).

Here is my rule for allowing my email:

[b]ALLOW-check the checkbox to log

Source IP: ANY
Destination IP: (pop.ispname.com,the IP address of your email server, or ANY if you don’t know what either of the first two are–I use the hostname as some ISP’s have more than one server IP address so this will cover all of them

Source Port: ANY
Destination Port: use your email port number here(25 or 110) or you can use a zone here which already has ports 25 and 110 in the zone list. Just click on the dropdown box on the right after choosing “Zone” and choose “POP/SMTP PORTS” and click on apply then apply again to save the rules.

You then want to make sure the rule(s) you created are above any BLOCK rules by using the "MOVE UP/MOVE DOWN buttons on the right or you can highlight a rule and hold the left mouse button down and move the rule up or down that way. [/b]


Thank you Jasper for your reply.

I hate to appear REALLY stupid, but how do I get to the screens that allow me to duplicate the email rules you mentioned?

Hi Jasper - thanks for your reply. I too do not understand the rules very well. I have doen the following:

  • set: Defense > Computer Security Policy > SpysweeperUI.exe > Installer/Updater
  • set: Defense > Computer Security Policy > Spysweeper/WRSSHP.exe > Installer/Updater
  • set: Defense > Computer Security Policy > Spysweeper.exe > Installer/Updater

Then in:
Firewall > Advanced > Network Security Policy > Application Rules > SpysweeperUI.ex > Allow And Log IP Out From IP Any To IP Any Where Protocol Is Any

But this does not appear to work. Is there something additional that I need to add here?


To get to Global Rules:
Firewall>Advanced>Network Security Policy>Global Rules>Add button on the top-right.


You might try changing the SpySweeper components to Trusted Applications. You also need to add the email rule to Global Rules that I suggested in my previous post.


Hi all,
I’ve tried just about all the suggestions and nothing worked. I’ve reverted back to the previous version of Comodo for now. I just started using Thunderbird for email but I don’t think it is a problem with this. It just seems like SpySweeper and Comodo V3 do not like each other. Let me know if anything changes.

Thank you, Jasper, for your reply. I appreciate you taking the time to help.

Unfortunately, the new rule did not solve the issue. So for now, I’ll turn off the email shields section in Spysweeper until the good folks at Comodo figure out what is happening.

As an aside to you (and anyone else reading this), I think V3 is a quality, effective product. However no product can be all things to all people, and for now there are some growing pains with the new version. I am confident (given your level of assistance as well as all the other folks trying to help) that the problems WILL be resolved.

Thank you again

Since I don’t have SS installed now I was trying to see if the rules or SS is the cause and from some of the other threads it looks like something is conflicting between SS and CFP3.

I think the devs have got most of the problems narrowed down to a few causes and they are working to get those fixed.



Great jasper, I hope they work it out. Thanks