v3 and BOClean

Where do I find the File Explorer window thanks?.

You could try it the other way around:

D+ → Advanced → Computer Security Policy → Edit (CFP Custom Policy) → Protection Settings →
Modify Interprocess Memory Access → Add path to BOCLEAN → go through every Apply button

That’s what I had to do for SpywareTerminator.


The File Explorer is in the File menu on the Excluder’s menu bar. I recall that I could not see the Excluder entry on the Right-click menu for BOC (Right-click the BOC tray icon) the first time that I looked until I dragged the lower frame down to reveal it.
As for defining the rule permitting BOC in Defense+, that is necessary, but it will not prevent BOC from triggering the CFP alerts when it tries to inspect CFP’s processes in Memory.

I install a lot of software in my job and find it incredible that Comodos applications can’t work alongside each other! They should rush out a bug fix pronto. My v3 firewall is going nuts over cavaud.exe and Boclean, hundreds of popups, tried every combination of “allow” but still I have a sore finger tapping the mouse key all the time!
v2 worked great. v3 looks nicer but is almost unusable if you have other Comodo software running.

Thanks for that Anotherone.javascript:void(0);

Like all of you, I clicked till my finger was sore. None of the suggestions of above seemed to correct it. Maybe if I were a software engineer I could fix it, but I have other things to do than chase down phantom false alerts.

My solution was to remove BOClean and keep CFW 3. Maybe I should have done the reverse, but for me this seems the best solutiion.

Seems at a minimum Comodo could make their own programs run seamlessly together.

If you are having to repeat permissions, there are two likely culprits. First is the possibility that the problem program is trying to access CFP processes that are protected no matter what privileges the program attempting the access has. This will always generate an alert, but clicking “Allow” does not generate a rule because it leaves CFP vulnerable to hackers. To get rid of these pop-ups, you have to open the software that causes these alerts and tell it to ignore/permit/exclude/call safe or whatever designation will get it to leave CFP alone.
Second, there is a known problem that results in a previously written rule to stop working. You will get pop-ups that say that the Program is Unrecognized and ask you to “Allow” or Treat as… with a few choices in the drop-down beside that option. If this happens repeatedly, try the following. First, get CFP on the software’s ignore list, if there is one. Then, click Firewall>Advanced>Network Security Policy. From that window, scroll down and select the entries for the problem program and “Remove” them. Then click Defense+>Advanced>Computer Security Policy and “Remove” any entries for that program from that window also. Then reboot and start the program. Select the needed level of privilege for that program (Trusted for security software) from the pop-up windows by selecting “Treat this Program as…” and choosing the pre-defined policy from the drop-down beside the option button. This should work, but if it doesn’t, please let us know. A fix should appear shortly.