v3 276 crashes very often:(

hi i have tested 273. i have completly removed this version and installed 276. i have the problem that very often after reboot the firewall say " cant start comodo because of problems" when i use the repaire funktion and reboot it works but all rules are lost. this error comes very often (i think 1 of 10 reboots). 273 i had the same problem:( any help?

First, we’ll need your details: CPU/memory; OS and updates; Security software/scanners/startup tools/etc.; details of the crash (BSOD? freeze? error messages?); any ideas on the cause could be useful. Then, as a temporary fix for the lost rules, click Miscellaneous>Manage My Configurations>Export. On the balloon, click the configuration named there (probably only the one entry) to open the Save dialog. Save the configuration somewhere easy to find again for the next crash and click Save. You can then Import the configuration and Select it the next time this happens to keep your rules intact. Note: Import does not apply the old rules. It only adds the configuration to the list of configurations that you can Select.

sorry for missing details:

core2duo notebook (asus v1s)
Windows Vista 32Bit (since yesterday with SP1 RC but the error was there befor installing SP1 too)
AntiVir Personal Edition Classic

after starting windows theres an error message “cpf.exe coundn t be startet because of problems do you want to start the diagnostics tool?” when i start diagostics he say there are errors and they are solved… after a few reboots same problem again:(

this is the error:

i wonder because comodo is installed on c:\ not e:\

It sounds like something went wrong with your installation of CFP. I would uninstall it and try again. First right-click the Avira tray icon and uncheck Antivir Guard Enable (may not be necessary, but no need to take chances). Then uninstall CFP. Next, open Explorer and check that C:\Program Files\Comodo\Firewall has been deleted or at least is empty. Also check E:\ to see if there is a Comodo Firewall directory there. If there is delete it. Reboot and make sure that Avira’s Guard is turned off. Finally, install CFP again before turning Avira’s Guard back on.

same problem after reinstalling with your advices :frowning: no same error dialog appears but with following text: “CPF.exe is not being started from the installation directory. You should run it from \Devices\Harddisk\Volume2\Program Files\COMODO\Firewall to make function properly. Do you still want to continue?”

After installation there was an Dialog from Windows Defendet with “Microsoft want to know more about this file” and then a file from COMODO installation. Could it be that Windows Defender is the Problem?
Any usser suggestions?

Windows Defender might be the problem. You should try turning it off, uninstalling CFP and then rebooting and reinstalling (after making sure that Windows Defender is still off). You might also want to have a look at:
Sometimes, registry remnants from previous installs of CFP itself can be a problem.

Seen this one before. I think it the last big unfixed bug

i have done all things from the posts but nothing helps:( could it be that my esata external harddrive is the problem?

most definitely… that is the bug

It sure looks like the source of the trouble. Would you post a bug report please? More reports are more likely to get a speedy fix. Include your system details and be sure to mention the eSATA drive, your system configuration and software installed, as well as the circumstances that cause the error message. Basically the info requested on:

my config:

core2duo notebook (asus v1s)
Windows Vista 32Bit (with SP1 RC but the error was there befor installing SP1)
AntiVir Personal Edition Classic

Seagate FreeAgent external ESATA-Drive
(this is the Volum E: which is namend in the error dialog i have posted. (but comodo is installed on c: )

i have deactivated antivir but nothing happens:(

hi i think i know why my comodo crashes with the error i posted. everytime i boot my notebook with my externel e-sata drive (e:) all is ok - no error. if i boot without the external drive connected the error appears! so everytime i boot my pc without that external drive there is an error. i have installed comodo with esata dribe connected and the installer was located on that drive…

That makes sense. The registry was looking the CFP files at bootup and since the drive was disconnected, it couldn’t find them. You might want to uninstall and re-install on your C:\ drive to avoid the problem.

no no no comodo is installed to c:\Program Files\Comodo !!! thats not the problem.

ony the installer was started from drive e: but install path is c:\ !

Sorry, I misunderstood. You would not think that just installing from the E:\ drive would require that it be connected for it to work. Even so, you likely can fix the problem by re-installing from the C:\ drive. I think that this glitch qualifies as a bug. Would you please put the details of what you’ve put down here into a report and submit it to:

A search for “Installation Directory” will reveal this a very well documented bug by now and not caused by anything the user is doing wrong.

Comodo Firewall just needs to be fixed.

Is there anything i can do? This bug isnt fixed in the newest version:(

Have you tried uninstalling the program and then copying the installer to your C:\ drive before re-installing? It does not have to stay there after installing (AFAIK), so install it and delete the installer. Turn off any AV/AntiSpyware software and reboot before uninstalling and re-installing CFP to avoid conflicts.

yes i tried this :frowning: