v3.0.22.349 installation hangs if you try to install in any drive other than C:\

I had v3.0.18.309 installed on my Windows XP. I recently uninstalled it to install v3.0.22.349. During installation, if i specify to install in any partition other than C:, …the application hangs consistently. The older version was working perfect!!, …Pls help.


I have a P4 HT, My system internet browser is Firefox, OS: XP sp2 32bit
AV: None
Security Apps: Comodo Firewall Pro 3.0.22

I was able to install CFP on another HD without issues.
On reboot CFP ran fine and started to train its configuration by means of alerts.

Does the installer hang on your machine or it is CFP itself after reboot?


I have been experiencing a similar problem with version and some previous versions.
see https://forums.comodo.com/bug_reports/the_bug_continues-t22170.0.html
After installation my computer just keeps looping at bootup. This happens whether using Firefox or IE.
I have Windows XP pro.
I find that version installs and runs with no problem at all, so I am stuck at that version unless I return to ZA, which I don’t want to do unless my working version of Comodo becomes vulnerable to future attacks.
Whatever is causing this hang at bootup ‘looping’ in later versions is not present in version
Do you know if anyone is working on this problem?

Hello Gibran,
Thanks for your help.

My OS is Windows XP Home SP2 Build 2600, Processor =Genuine Intel X86 based1.66GHz, 512MB Memory. Machine=Lenovo 3000 series laptop Model N100.
Internet Browser= Internet Explorer 7
I have tried on my other p4 desktop too, but same results. I hope you understood my problem. During installation, it installs on the c:\ by default, but you have an option to install it on other partition/ drive. I can click ‘browse’ and select the location.

This is the part where it hangs…
-Choose Destination Folder
-Select folder where setup will install files
-Setup will install comodo firewall pro in the folowing folder
-To install to this folder click next. To install to a different folder, click browse and select another folder.

But the minute i click browse, the installation hangs & shuts down. It installs perfectly if i don’t click browse & let it install with its default option, which is c:.

Everything works perfectly with the following installation file…

I can click the browse option during installation & install it in my ‘D’ drive/ partition.

It hangs when i use the following file…

I already had a working installation on my machine which i had installed using “CFP_Setup_3.0.18.309_XP_Vista_x32.exe”
But i recently uninstalled the old version & downloaded the latest file “CFP_Setup_3.0.22.349_XP_Vista_x32.exe” from the comodo site to install.

I have no option but to use the old installation file to install it in my ‘d’ drive. & later upgrade to the latest version using updates feature.

PS: Once installed the old program version worked perfect before & now too (both in the D drive)
& Even the new one works perfect, if you install it in its default location that is C:.

Hoping for a solution,

Hello Gibran,

I ran Ccleaner to clean my registry. Now it installs perfect.

thanks again for your help.