V- D+ settings to allow Firefox downloads

I am not able to get Firefox to allow downloads with D+ activated. I have the identical settings in D+ as well as in Network Security Policy for FF as I do for IE7 but it gives me the following message. (see attached photo).
I have tried reinstalling FF twice. I have tried various settings for D+. I have searched for a solution on the forums to no avail. It does work with D+ disabled, so I know it is not my FF settings. Download works well in IE7.

Has anyone else had this problem and if so how did you get it working?


XP Home SP2 32 bit, Pentium D 3 Ghz, Ram 1 GB, BOC, CAVS, CFP3, CMF

[attachment deleted by admin]

You should look at firefox protected files settings and set it to ask. Later you can edit one file in the allowed list to repace the filename with a *

Haven’t had the problem, but setting Opera to Installer or Updater made all of the messages go away when I download and execute things. I am using Free Download Manager with Firefox, and it also works fine with that setting. There is also still an error in the Predefined Firewall Policies if you are using them-Allow FTP for a Web Browser still only allows port 21, and you need to change it to any.

I just uninstalled Online Armor and installed the new and improved Comodo and have no problems downloading files. I download everything into My Briefcase. Whatever problem you have I dont believe its Comodo.

I changed the browser allow ftp from 21 to any. No better. Put FF in the protected file settings, it was already set to ask. Edited the FF protected with a *. Worked :BNC

Thanks for all your help


I will mark this as resolved.

Did you import your .273 settings or start over again?

I started over. I wanted to see what differences there was without any leftovers from the previous version. I guess I found one anyway.


please what i have to do exactly ?
i have the same problem

i dont understand very well (:WIN)

anyone please explain me step by step… :-\



Simplest thing to try first is to fix the ftp rule for Web Browser under firewall/advanced/predefined policies. Go to Web Browser/edit/Allow ftp out/edit and change the rule to allow/tcp/out/any/any/any/any . Currently the allowed destination port is only port 21, and that usually blocks passive ftp.

i will see if the problem disapears and report something !

but why is an eror with so strange and random .exe names ?

thank you

edit: the problem continues :cry:

I had the same problem Friday with .276 on vista x64 and it appeared out of nowhere… I tried to change rules for firefox and kav, because i thought it was compatibility issue between both applications, but nothing helped, so I gave up. then I decided to re-install comodo and the pop-up disappeared… go figure…

Sorry I haven’t been much help to you on this. I had it fixed as my post above stated but it returned for no apparent reason today. I checked my settings are still ok. I will try reintalling firefox to see if that helps.


I will try reintalling firefox to see if that helps.

Made no difference!

very strange problem !!!

i have tried various security software and nothing is detected… including anti spywares and anti-trojans


Just did a re-install of CFP 3 and it did not make any difference. This is the only glitch that I have with CFP and I just can’t get it to work so that Firefox allows downloads. Is there some way that I can check what is happening when I click download on FF? I tried logging when FF rule is fired and the logs say everything is allowed. I have tried allowing the temp* folder as safe, I have tried allowing all of FF as safe. I need some more ideas.


Just disabled CFP firewall security and Defense+ and it didn’t make any difference. Must be something wrong with Firefox. Tried FF version same problem.

are you sure that isn’t a virus ?
a just want to have sure…


Does FF fail on both http and ftp downloads? And all sites? Did you log all of the rules? Are you using the attached ruleset with all ports allowed for ftp? Is FF set as a trusted application? In FF options/main do you have FF configured to show the download window? When you try to download, does nothing apper or do you get an error message? I don’t use CAVS-does it scan web traffic?

[attachment deleted by admin]

its a very strange problem… sometimes gives me an error while downloading and sometimes download correctly…


i dont understand here the problem is… :-X

Make sure you have the DNS rule in your ruleset. Sometimes the downloads are on a different server/IP address than the actual website. Is ftp download vs http download a factor? What error do you get when it doesn’t download correctly?

Thanks for all your help sded and seed.helper, I’m sure we will eventually get it figured out.

John - Did a Trend Micro scan for viruses - nothing

Also the blocks in my log are before I switched to any from port 21. Now the logs all say allowed for everything.

[attachment deleted by admin]

[attachment deleted by admin]