uTorrent's Listening Port is Blocked [Resolved]

Hello there, just installed Comodo PF 3 and uTorrent (which I managed to setup nicely with version 2.x) has stopped allowing incoming connections, as far as uTorrents built in port checker is concerned, my port is closed!

I tried the old way of setting it up, what I did was click on the Firewall button on the top, then the Advanced button, go to Network Security Policy, then Global Rules tab and Add a new rule as follows:

Action: Allow
Protocol: TCP or UDP
Direction: In/Out

Source Address: Any
Destination Address: Any
Source Port: Any
Destination Port: my open port

And I moved the rule to the top of the rules list and checked again in uTorrent, but still wouldn’t work.

Any help will be much appreciated! :stuck_out_tongue:

You need to go into Firewall/Stealth ports wizard and set Alert me to incoming connections. By default Comodo Firewall 3 blocks all incoming connections. Then set up application rules for utorrent. There is no need to echo these rules in global anymore.

Ok I tried that, went into Stealth Port Wizard and selected “Alert me to incoming connections” and clicked Finish then “Your firewall has been configured accordingly” shows and I restarted my PC, but nothing happened (if some alert about uTorrent was supposed to pop up, it didn’t!)

It might be worth mentioning that when I go into the Stealth Port Wizard again the first option ios selected, not “Alert me…” and uTorrents port checker still says the port is not open.

Are you using Peer Guardian? Last month or so the page of uTorrent got blocked by PG. If the page is still on the list make an exception for the website (you can see the ip getting logged; so you can unblock that ip address).

I’m also having problems getting the rules to work. This is what I have.

  1. Allow TCP/UDP. From IP any to IP any. Source Port is [my utorrent port]. Destination any.
  2. Block and Log IP from Any IP to Any Where Protocol is Any.

It worked fine on 2.4. Why doesn’t it work now?

Edit: Nevermind. I mixed Source with Destination. Works now. (:SHY)

Read this FAQ to learn more on how to deal with p2p clients: https://forums.comodo.com/faq_for_comodo_firewall/tutorials_a_compiled_resource-t6167.0.html;msg45504#msg45504 and this FAQ by Gibran: https://forums.comodo.com/help/faqsthreads_read_me_first-t9364.0.html .

Hi guys, I got it sorted thanks, I added the global rule and the application rule and I also had my NAT on my router set up wrong (d’oh!) :-\

But it’s sorted now.