Utorrent unable to acheive green symbol

Hello there…

I am trying out The Comodo Firewall Pro and did the install under the installed recommended settings. I had the red circle with an exclamation mark appearing on my utorrent . I did not encounter the red symbol while I had Zone Alarm Pro, however because of the frequent crashes of BSOD caused by “vsdatant.sys” [Part of Zone Alarm]. I decided to give Comodo Firewall Pro a try.

I followed through the recommendation on the TCP and UDP settings that is given under this thread https://forums.comodo.com/index.php/topic,9045.0.html but still facing the same issue.

The following applies to my situation :

  1. I am connected through a cable modem and I do not have a router , so the issue of port forwarding does not arise here.

2.I did complete clean uninstall of Zone Alarm to remove any configuration that might remain.

3.I even tested by disabling Comodo Firewall Pro . I also disabled under Control Panel=>Adminstrator tools=>Services => "Windows Firewall Internet Connection Sharing (ICS) " but I am still remain unconnectable.

I have run out of ideas how to solve the problem I am facing now…hope someone could help me here.

Vangtech, welcome to the forums (:WAV)

For item #3 you say you tested by disabling Comodo FW.

Will you please let us know what steps you took to “disable” Comodo FW?

Also just to clarify, after having done so, you still could not get a green light in the p2p app?



Hi Little Mac (:WAV) , nice to be here and that was a really fast reply :BNC

I disable Comodo FW by right clicking the icon that appears on my system tray and then click disabled . After doing that…I am still unable to get the green light …Can’t really figured out what seems to be the problem .

Btw, Windows XP firewall is also disabled… I would appreciate if someone could really solve the problem I am facing now.

Well, if you have turned off the FW and you’re still blocked, we’re looking at a deeper issue than regarding FW rules. Okay, let’s try this; this may be the quickest way, ultimately.

Go to this thread https://forums.comodo.com/index.php/topic,2366.0.html for a batch file and instructions for how to create a backup of your current settings for Comodo FW (if you have a lot); otherwise, we’ll start over.

Turn off any active security software (AV, AS, HIPS, etc). Uninstall the FW - go to Start/All Programs/Comodo/Firewall/Uninstall (let’s go this route rather than Windows Add/Remove applet). Reboot when finished. Run your favorite registry cleaner (be sure to use the backup option, just in case) just to make sure there are no orphaned entries (if you don’t have a “favorite” may I suggest ccleaner or regseeker, both free), and reboot again.

At this point, I’d like you to test if you can get a green light with utorrent. Since you’ll be connected in a big way to the internet, you may want to enable the WinFW again. If you can’t get a green light now, there’s some other issue. If you can, then good (hopefully you will, and we move to the next phase).

Disable the WinFW, and once again turn off any active security software. Re-install Comodo FW, choosing Automatic rather than Manual for the install mode. Reboot when finished. Import your old settings (if you exported them before) using the instructions in that thread. This way all your rules will be back.

Then try utorrent again and let us know how it goes.


PS: sorry for the uninstall route; I want to make sure we have a clean slate to start from.

The easiest method to install CFP in a clean environment without having to worry about disabling other programs is in the classic Safe Mode.

Hi Little Mac

I really appreciated all the help you have given me …many thanks for that…

As for the backup you have suggested under this thread
https://forums.comodo.com/index.php/topic,2366.0.html . I did not apply it as there were not much of a configuration to Comodo FW at the beginning . I am still at a learning process and trying to understand those functions . The only config I did was TCP & UDP settings and had given exclusive rights to utorrent to access the net. If any, I could just manually reapply those rules again.

The other security application I had is a trojan hunter “Tauscan” that runs at system startup. I had Tauscan disabled , uninstalled Comodo FW as you have suggested under this path Start/All Programs/Comodo/Firewall/Uninstall . Did a cleanup using CCleaner and did a registry integrity check as well. It did manage to detect some absolete entries as well as some of those that belong to Zone Alarm and those will removed as well.

Did a reboot then proceded to reenable my windows XP firewall.

However my utorrent is still showing I am still unconnectable [red exclamation mark still appears below]

Hi Soya.

Thanks for your input .I will give that a try using safe mode and will let know the outcome…

Hi, Vangtech. Was/is it just uTorrent? What about other internet activities like browsing websites and your d/l & u/l speeds?

Hi Soya,

I did not have issues when browsing websites but the P2P is kind of slow . I believe this is mainly because I am in unconnectable state .

However , I did not have an issue concerning this when I had Zone Alarm installed and my utorrent is always showing the green symbol and my downloads and uploads speed are within expectations.

Anyway, I can’t continue with Zone Alarm as it is causing the BSOD too frequent . I need to find an alternative .

I am beginning to thing that the uninstallation of Zone Alarm has something to do with me been unconnectable .

No surprise :); it wouldn’t be the first report here. Some links for extra ZA uninstallation suggestions:

Wow Soya (:AGL) that is a wealth of information in there … will try it out…and keep you posted on the outcome…Thanks

Hi Soya & Little Mac

To remove traces of Zone Alarm from my PC , I did a reinstall of Zone Alarm [Just in case the first unstallation wasn’t done right] and then apply the uninstallation listed below.l
I have try out all of this :

1 .Under Zone Alarm Preferences =>uncheck Load ZoneAlarm at startup => Proceed to Reboot .

  1. Uninstall ZA applying this parameters => C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe" /clean [A message confirms the uninstallation was a success]

3.Applied “zfix.cmd” to remove any remanants of Zone Alarm.

4.Go to Start > Search > Files and Folders. for the following : Zonelabs; “zone labs”; “Internet logs”; vsconfig.xml; vsdata.dll; vsdata95.vxd; vsdatant.sys; vsmon.; vsmonapi.dll; vsnetutils.dll;vspubapi.dll; zaplus.; zapro.; zllictbl.dat; zlparser.dll; zonealarm.exe; zoneband.dll; vsutil.dll; zlclient. [None of this will displayed on the search as I presumed the first uninstallation using this command C:\Program Files\Zone Labs\ZoneAlarm\zauninst.exe" /clean had taken care of this.

5.Tried “zabegone.reg”
[-HKEY_CURRENT_USER\Software\Zone Labs]
[-HKEY_LOCAL_MACHINE\Software\Zone Labs]
[-HKEY_USERS.DEFAULT\Software\Zone Labs]


5.Applied CCleaner to remove all obsolete entries without the advanced options enabled .

Can someone please explain, do I need to enabled this advanced options (default is untick) i.e Old prefetch data, Menu Order Cache,Tray Notification Tray, Windows size /Location cache, User Assist History, IIS Log file, Hotfixes uninstallers , Custom Files and folders. . Sorry for the noob question on this .

I have set my windows XP firewall at default settings but applied the exception rule for utorrent to connect .

After all of the above, my utorrent is still showing me as unconnectable …I am running out of suggestion here …Any help would be greatly appreciated.

Anything blocked in the CFP log? It would help if we can see your App and Net rules and log uploaded here.

Here’s a thread from the FAQ in which I linked to get it green:

i had to open tcp in for the port my utorrent is using.
that’s how i got the green icon