Utorrent Rule

If you follow these instructions, you can connect uTorrent with only One listening port. Disable UPnP Port Mapping by opening the preferences menu in the options menu at the top of the main window. On that same tab Copy the port used for incoming connections.

Goto your Firewall and open the Network Monitor and right click the network controls and open add rule----> Add.
Now;

The Rule
Action:Allow
Protocol:TCP
Direction In

Source:Any Destination:Any Source Source port:Any Destination:(Paste your port HERE)

Once you have created this rule move it up in the list above the red Block&Log Rule…Done!

That is the only port that needs to be allowed to listen for an outside connection request.

uTorrent is in MY opinion and that of my Friends and affiliates the Best client, by far less memory hoggish than Azuereus. and others of its kind. and fully functional and informative, without all the confusion of graphics and ads…Just the Torrent…That is what its all about, and did I mention Comodo firewall handles the mass connection attempts and fake syn requests that seem to be frequent among torrents…Anyway, does it all well without slowing your downloads/uploads, or your PC…

Dear CS5

Thank you for your instructions for using Comodo Firewall in regard to uTorrent.
Maybe this worked in CF 2.4, but does this also apply for Comodo Firewall 3.0 ?

I installed Comodo Firewall 3.0, but got a NAT-problem in uTorrent I couldn’t resolve.
So I turned back to Comodo Firewalll 2.4. My OS is WinXP-SP2.

Thank you for your answer,

Apeidron

Agree with that. Settings in Version 2 doesn’t work in 3. Any guess?

This is now driving me completely bonkers. Since installing Comodo ver 3, my uTorrent connection has become unusable. I’ve tried everything. I’m currently using the 5 rule configuration cited elsewhere in the forums - different to this one - but whenever I connect, the settings don’t appear in the overall network window (CM5s 2nd png). All I get is an IP rule allowing everything, whereas my rule 5 explicitly blocks all IPs.

How can I get this working? Comodo has been great but unless I can sort this, it has to fall by the wayside.

The 5 rule set posted by Pandalouk (sp)? …

µTorrent

How to configure Comodo firewall 3 for µTorrent.

  1. Go to : Firewall → Advanced → Attack Detection Settings → Miscellanous and disable Do Protocol analysis

  2. Go to : Firewall → Advanced → Predifined Firewall Policies and select Add…

Give a name at the new Predifined Policy for example: µTorrent

Add the following rules:

Rule 1

Action = Allow
Protocol = TCP or UDP
Direction = In
Description = Rule for incoming TCP and UDP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = the port of utorrent

Rule 2

Action = Allow
Protocol = TCP
Direction = Out
Description = Rule for outgoing TCP connections
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = A port range = (start port = 1025 / end port = 65535)

Rule 3

Action = Allow
Protocol = UDP
Direction = Out
Description = Rule for outgoing UDP connections
Source Address = Any
Destination Address = Any
Source port = the port of utorrent
Destination port = A port range = (start port = 1025 / end port = 65535)

Rule 4

Action = Allow
Protocol = TCP
Direction = Out
Description = Rule for HTTP requests
Source Address = Any
Destination Address = Any
Source port = A port range = (start port = 1025 / end port = 65535)
Destination port = 80

Rule 5

Action = Block (enable Log as a firewall event if this rule is fired)
Protocol = IP
Direction = In/OUT
Description = Block and Log All Unmatching Requests
Source Address = Any
Destination Address = Any
IP Details = Any

  1. Start utorrent. When Comodo asks you with a popup, choose ‘Treat this application as’ select utorrent and enable Remember my answer.

If you have connectivity problems:
Go at Firewall → Common Tasks → Stealth ports wizard and select
Alert me to incoming connections- stealth my ports on a per-case basis


Working well for me.


Do you have any old rules for µTorrent lurking around in Comodo V3 that may be causing your problem?

In addition, when I first made the rule I didn’t click all the ‘apply’ buttons and found µTorrent wasn’t working. Went through the rules again making sure I ‘applied’ them all and it’s been fine.

My rules appear in the Network Security Policy and in the Predefined Firewall Policies.

Those settings are working for me (:KWL)

thx man very nicely described. i’m kind of upset on comodo becouse this is an important rule for many users of comodo and it should have been posted from the beginning.I know they have other important issues to solve,and correct the bugs ,but this should have added to the manual if it is the most reliable of course. (B).

I’d like to see a list of common application rule sets too although that may run into hundreds, maybe more!
You’d need dedicated staff or volunteers to run through program after program and posting up their rulesets but that would be really helpful to many I’m sure.

Thanks for the rule set. However, I have a small problem after setting them up. I’m getting a tracker error. Tracker Status: hostname not found. Also, I used to see (in uTorrent) the IP# of the connected peer and usually their IPS name, now it just shows the IP#.

This isn’t confined to just one tracker, it’s been the same for every tracker I’ve tried. (:SAD)

Using the latest (stable) version of uTorrent, OS is XP Pro SP2, Comodo 3.0.13.268

I’m behind a router, have the firewall within it on. Have uTorrent’s port forwarded and have my router set to not respond to ICMP (echo request).

In the router’s firewall settings:

Service:
HTTP - Port 80 In/Out
DNS - Port 53 In/Out

It’s because Pan’s ruleset is missing one for certain people like us: the Allow Outgoing UDP to Port 53 (you can further specify your DNS server’s IP address if you want to be secure or paranoid).

https://forums.comodo.com/frequently_asked_questions_faq_for_comodo_firewall/tutorial_for_utorrent_with_comodo_firewall_3-t15677.0.html;msg112206#msg112206