Utorrent [Resolved]

Hi there, first time posting on any forum so hope I’ve posted in the right place! :-\

Any suggestions would be gratefully received. To achieve the green symbol on utorrent I had to adjust my settings on my Comodo firewall to the following: (as suggested in previous posts)

Action = Allow
Protocol = TCP or UDP
Direction = In
Source IP = Any
Destination IP = your IP adress (or “Any” )
Source port = Any
Destination port = the port your bittorent program uses for the TCP/UDP connections

After this setting I do manage to achieve a green symbol on utorrent though unable to browse the web. I’ve also tried the above setting my Direction to In/Out - but still can’t connect to the internet.

I do manage to get the Green symbol if I just click on “any” for all the choices (with an In/Out Direction) and can still browse the web. Just worried if I’ve compromised my security or not?

Any ideas? Thanks

p.s I don’t use a router.

Hiya! Welcome to Comodo!

I don’t use Utorrent but I believe there are some particular network rules to setup in order for it to work. Have a look at our FAQs and there’s a couple of Network Rules Topics. I think the second one from the top in our FAQ Forum page has a collection of Network Rules for peer-to-peer stuff I think even specific ones for Utorent!

If you need any further info, just ask…

Eric

  1. run utorrent , in Options → Preference → Connections
    untick “Random port each time utorrent starts”
    untick “Enable UPnP port mapping”
    Select the port you want to use.

  2. Add Network rule for utorrent in firewall (the port must equal to Listening port in utorrent, or the port you chose)

  3. run utorrent , in Options → Speed Guide
    Click “Test if port is forwarded properly”


The network rule must be moved up above the ‘block’ rule.

Network monitor

  • id 0
  • permission >allow
  • protocol tcp/udp In
  • source > any
  • destination > any
  • where source port is (any)and destination port is (12345) (use the port you have chosen for Utorrent)

application monitor utorrent

  • destination >In

  • port >(12345) (the port you choose for Utorrent)

  • tcp/udp >in

  • permission >allow

  • destination >Out

  • port >Any

  • tcp/udp >in

  • permission >allow

Thanks EricEgan for your warm welcome and links & thanks alot JolietJake for the help! The problem solved! I really did NOT want to change firewalls, and I think I’ve tried them all now! Nothing comes close to Comodo in my humble opinion! (R)