Utorrent problems

Hello i set Uttorent to be threat as web browser, and have setup create rules for save applications, but still when i chek firewall events there is huge list of blocked addres from Utorrent, and my downloads accelarate very very slow, it needs like 10 mins for torrent to start downloading as it should, (during this time the torrents are red) and even when the speed get normal after few mins it drop again to very low transfer…

Is there any easy/fast way to make Utorrent work as it should? (its already a safe application) i saw one guide but its kinda long…

Utorrent should not be set as a safe application nor as a web browser.

Read here for the right settings


Thanks for the link, but seems the thread is quite old, i tought there is some easy way now? those are quite long settings… :frowning:

The first post in that thread - (the one you should use) - has been updated very recently.
–Look at the bottom of the post–

I understand that it appears complicated to make those rules, but they only take a few minutes to

What I did was – I copied them to my notepad and kept it in my taskbar so that I could copy&paste the
rules into the appropriate boxes. That way you can’t make a type-o.

If you want to Torrent, you just have to do it.
I’m a complete noob and I was able to do it.

I use those rules myself with BitTorrent (except I don’t log when a rule fires).

I suggest you add the necessary port in global rules. I will give you an example how to add a port in the firewall so do not add that port!

EXAMPLE: add port in firewall
To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok

I am sorry if I sound unfriendly and I hope this will help. adding it in as trusted application in Application Rules should be enough.

Valentin N

Thanks guys for you help! acutally i added the first 3 rules of the 1 post only, and now the torrents run as it should :slight_smile:

Thanks again for you detailed response, this forum is the best! :rocks:

Ok guys the issue appear again, i tried to ad all of the rules but here is the problem.

When finishing all of the options for particular rule i need to click apply, but when i do it says u need to give a name, so i do like on start…as the OP said in the guide to name it Utorrent, but when i do that for second time i get msg, Utorrent entry already exsist!? so i cant apply the changes for the rule…can i use any other name (utorrent1, utorrent2) and the settings still work for original Utorrent entry? i 'm really lost here :frowning:

In short, Predefined Policy for example: utorrent- when i do this at start is ok, but later when i need to apply the settings it says that policy/name/utorrent already exists and nothing happens…

Also Rule 1

Destination port = the port of utorrent? what do i need to enter here from the options? a single port - add any number from 1025-65535? or again a port of range and add 2 ports like in many of the rules?

And for end, when Firewall pop-up about Utorrent connecting, i cant see option to threat as Utorrent only the standard options, this happens even after in Application rules Utorrent is already named as Utorrent…

It sound like you already have a rule for uTorrent, hence the message.

If you are having problems, take a look at the three images below. the first is the uTorrent preferences, it’s here you define your uTorrent port.

The second id for Application rules, just create the rules as listed here, making sure you have deleted any existing rules for uTorrent.

If you use LDP (Local Peer Discovery) you can add an additional rule:

Source Add - Any
Destination Add - -
Source Port - Any
Destination Port - 6771

The third id for Global rules. You don’t have to use two rules, I just did this for the sake of clarity.


[attachment deleted by admin]

Yes man i got rule for Utorrent, but only one rule.…i need to add five all in all, but i can add just one…not sure if u understand me here, when im finishing the first rule it says i need to give it a name but i already need to give name at start like the OP said in the guide…

Give a name at the new Predefined Policy for example: utorrent

And later when i fnish all of the settings when i need to click apply i cant, because that policy already exist and nothing happens :frowning:

So from the predefined polices menu there are 6 options, which one i choose because i cant add a new rule under the existing Utorrent tab, because it already exist this is my problem, in short i can add only the first rule from the guide (or i need to enter different name, but if i add different name the rules which i will add next won’t apply to Utorret i’m affraid…

Thanks for the help anyway :slight_smile:

  1. Delete any rules you have for utorrent.
  2. In Application rules, click Add
  3. Click browse
  4. Find your utorrent folder and click utorrent.exe
  5. Add rules as described above

Thanks bro will give it a try :slight_smile:

When you go to → Firewall → Network Security Policy → Predefined Policies →
is there a policy listed for Utorrent? (see the first attach. below)
If there isn’t, then you should just delete any rules you have already made
and start from scratch.

If there is a policy listed, you can right click it and select EDIT, and then add the remaining rules
that you should have added in the first place.
When you add them, you will have to ‘drag’ them into the proper order.
They HAVE TO BE IN ORDER to work properly.

And when you come to the part where it asks you to name it, just copy and paste the
name into the DESCRIPTION window. (see the 2nd attach below)

For example…

Rule 1
Action = Allow
Protocol = TCP or UDP
Direction = In
Description = Rule for incoming TCP and UDP connections
Source Address = Any

As for which port to use, refer to Radaghast post/attach showing the Utorrent

[attachment deleted by admin]

Ok guys with help of my friend i fixed it, just one more thing…i cant make Utorrent to be threat as utorrent…when firewall alert appears there is no option threat as utorrent even in application rules Utorrent is listed as utorrent, and on every restart of utorrent i get the same alarm i set as web browser and later again in application rules i change Utorrent from custom to Utorrent, do i have to do this all the time?

Thanks alot for the help and patience !

Would it be better if it’s treated as trusted application?

We thank you for letting us help you and for waiting for help :slight_smile:

Valentin N

But i was told Utorrent should not be threat as safe application? hence why i even add rules for it, i could add threat as safe application from the start? or the rules still apply even after you set utorrent as safe application?

Thanks guys i’m sorry for confusion :slight_smile:

No never treat it as safe or trusted, P2P programs are a major malware “threat-gate”

So you are saying that when you go to →
Firewall →
Network Security Policy →
Application Rules →
right click utorrent and select - Edit →
you tick the - Use a predefined policy button →
you select - utorrent →
and then you click APPLY
and then you click OK at the bottom of the page (see attach)
that it doesn’t remember?

If so something is very wrong.

[attachment deleted by admin]

Yes, after i do exactly what you said (and i can see all 5 rules listed under Utorrent entry in (application rulles) its setup as Utorrent.

After i restart Utorrent, i get firewall alarm,

Utorrent is trying to connect to internet,



Allow this request- threat this application as = no Utorrent setting…i have to press web browser and then change Utorrent from custom in application rules to Utorrent again, and again…

So you select Web Browser…but when you go to…Application Rules under the
Firewall … it’s listed as CUSTOM ??..instead of WEB BROWSER.

Anyway, the reason I emphasized…

"you select - utorrent →
and then you click APPLY
and then you click OK at the bottom of the page

is because once I made the mistake of not clicking APPLY and OK
and I was confused why Comodo was not remembering
my instructions.

But if your are clicking OK then all I can say is that
maybe some of your old rules are confusing the firewall and thats why
Utorrent doesn’t appear in the initial Firewall alert.

I’m curious, when you get the Firewall alert, what options are available
in the drop down list??

Yes it says Custom,

Ok will try to remove the rules and add them again :frowning: