uTorrent problems

I never followed the uTorrent sticky. I set my modem hardware firewall to use 1 port for uTorrent. Then I made uTorrent a trusted program and it turns gree. It only shows uTorrent connecting to port 53867.

Well aren’t you a lucky so&so…mine wont function without 'em.

I do think you’re right however - our friend here may need a clean slate of sorts.

I followed the port forward instructions when I went to there site. I plugged in port 53867 for in and out. Comodo doesn’t need specific rules for me cause its only connecting to 1 port.

As I said again and again, setting uTorrent to trusted doesn’t work! The traffic I need is showing up as “Windows Operating System” traffic, not as uTorrent traffic! Disabling Comodo or trusting WOS are the only ways I’ve managed to get uTorrent to work.

Comofo, I did what you suggested but not luck so far. It really seems as if the traffic from uTorrent is not being recognized as such by Comodo and it shows up as Windows Operating System traffic instead. I get blocks UDP Out to my uTorrent port, for instance, which is the traffic I’ve specifically allowed in the uTorrent app settings.

Unless someone has another suggestion, I could maybe try to allow some parts of the WOS traffic so both browsing and uTorrent work. Or would that be a bad idea? What do you guys do with your WOS traffic anyway?

I showed you a screen shot. Look at post 10 the top pic. I think your best to do a complete uninstall of Comodo. Then reinstall. Use Revo Uninstaller in advanced mode.

Does uTorrent turn green with Comodo uninstalled? I was having similar problems so thats why I started over from ground zero.

Yes, uTorrent works with Comodo uninstalled. I already tried reinstalling Comodo like three times, last time I used the sticky to get rid of all remaining registry settings and folders but still it won’t work.

There is no reason it shouldn’t work. What modem do you have? What port is it forwarded to?

Why don’t you try a different port. Use higher port numbers.

I’m using a Thomson Speedtouch 706WL and port 27613 is translated to 27613 for both TCP and UDP. That part seems to work as uTorrent runs green when i use it without a firewall or with the Vista firewall, for instance. Maybe it’s an issue with UAC hiding process names or something? I have no idea how Vista’s security features work so I may be totally off…

I also tried with a different port. Still works without Comodo, won’t work with it.

More news, I got uTorrent to work by applying its rules to the WOS service.
I combined the settings for the “Web Browser” profile with those for uTorrent. Could someone please have a look and tell me if this is at all safe?

[attachment deleted by admin]

That rule makes no sense to me what so ever. Why do you have uTorrent grouped under WOS? I think your global rules is what is screwing you up. Look at my screen shots. I only have 1 global rule and thats for echo request. I don’t even see that in your global rules. WOS only needs outgoing which includes svchost,explorer.exe and system. Sorry I did see that rule in your last shot.From my understanding and which works for me I don’t have a global rule set for uTorrent.

What I don’t understand is when you go to the Port Forward website it tells you to use 1 port in and out. Which for me is port 53867. Then your telling Comodo to use port 1025-65535 for uTorrent. I am no expert but this doesnt make sense to me.

Not sure how or why but one guy in the uTorrent forum was having problems, and although the screenshot was fuzzy, it looked like they unchecked “protected registry keys” in the D+ setting, monitor settings

LOL… Probably not related topic was Error:access denied

I can delete every rule except the ECHO one and it won’t make a difference.
Why uTorrent is grouped under WOS makes no sense whatsoever to me either but the fact remains that applying the uTorrent rules to the WOS applications is the only way to get uTorrent green short of disabling Comodo altogether.
It’s as much a mystery to me as it is to you but it seems like vital uTorrent traffic is being catalogued under WOS. Setting WOS to “outgoing only” means uTorrent won’t turn green.

You have a point though that using browser settings for WOS doesn’t make much sense. I’ll try using the Outgoing Only + uTorrent settings instead.

Can I ask what you have set your WOS to?

Here are the recommended rules from the uTorrent forum…

COMODO Firewall Pro

[RULE 1]
Action ............ : Allow
Protocol .......... : UDP
Direction ......... : Out
Description ....... : DNS Service
Source Address .... : Any
Destination Address : Any
Source Port ....... : Any
Destination Port .. : (A Single Port) 53

[RULE 2]
Action ............ : Allow
Protocol .......... : UDP
Direction ......... : Out
Description ....... : Multicast
Source Address .... : Any
Destination Address : (IP Range) 239.0.0.0 - 239.255.255.255
Source Port ....... : Any
Destination Port .. : (A Single Port) 6771

[RULE 3]
Action ............ : Allow
Protocol .......... : UDP
Direction ......... : In
Description ....... : Ephemeral Ports [IN] (UDP)
Source Address .... : Any
Destination Address : Any
Source Port ....... : Any
Destination Port .. : (A Port Range) 1024 - 5000

[RULE 4]
Action ............ : Allow
Protocol .......... : TCP or UDP
Direction ......... : Out
Description ....... : Ephemeral Ports [OUT] (TCP/UDP)
Source Address .... : Any
Destination Address : Any
Source Port ....... : (A Port Range) 1024 - 5000
Destination Port .. : Any

[RULE 5]
Action ............ : Allow
Protocol .......... : TCP or UDP
Direction ......... : In
Description ....... : Port [YOUR PORT] [IN] (TCP/UDP)
Source Address .... : Any
Destination Address : Any
Source Port ....... : Any
Destination Port .. : (A Single Port) [YOUR PORT]

[RULE 6]
Action ............ : Allow
Protocol .......... : UDP
Direction ......... : Out
Description ....... : Port [YOUR PORT] [OUT] (UDP)
Source Address .... : Any
Destination Address : Any
Source Port ....... : (A Single Port) [YOUR PORT]
Destination Port .. : Any

Where [YOUR PORT] is replaced with the port µTorrent listens on. These rules can be made global rules, but you’re probably better off making them application-specific.

In COMODO Firewall Pro v2.x:

  • Application-specific rules can be added via Security > Application Monitor
  • Global rules can be added via Security > Network Monitor

In COMODO Firewall Pro v3.0:

  • Application-specific rules can be added via Firewall > Advanced > Network Security Policy > Application Rules
  • Global rules can be added via Firewall > Advanced > Network Security Policy > Global Rules

NOTES:

* I made a lot of rules, but that's because I was trying to make the rules as tight as I could.

* The Multicast rule can probably be tightened down considerably for the Destination Address, but I wasn't entirely sure how specific I could make the rule without breaking µTorrent's multicast (should the IP ever change in the future), so I left it with such a large range. If I'm not mistaken, the one single IP µTorrent used for LPD was 239.192.152.143, but again, I'm not sure if limiting the rule to that single IP would cause any misbehaviors in the future. Adjust the rule if you really want to, but I don't think it's really necessary, since the range is reserved anyway.

* If you're using an alternative listening port for any reason, then you're going to need to create a copy of rule 5 for that port (though you probably won't need the UDP part of that rule -- I say probably because I haven't tested it).

* I don't use Defense+ in COMODO Firewall Pro v3.0, so I'm not sure how one might configure it (if it is at all necessary to be configured, that is). At least one user has had to configure some setting in Defense+ to make COMODO work properly with µTorrent -- see the relevant thread here

http://forum.utorrent.com/viewtopic.php?id=33080.

I told you what I have WOS set to. Look at my screen shots. WOS has nothing to do with uTorrent. I don’t have an entry for WOS but I have an entry for svchost,explorer.exe and system which is part of WOS.

Hey Hikertrash if you see his first post he already did all that. I myself didn’t have to do any of those rules.

Oh sorry. (:KWL)

I see. So WOS is a Vista-type thing then? I remember I had svchost and explorer rules back when I was still on XP and they never caused me any problems.

And I’ll say it again, in my case WOS DOES have something to do with uTorrent. According to Comodo’s definition, WOS is a pseudo-application containing sub-applications that could not be recognized by Comodo. So while that usually means svchost and all that, it’s not necessarily only those apps.

And my log clearly shows that when I set WOS to Outgoing Only, connections that conform with the ones I’d expect from uTorrent are getting blocked by Comodo under the WOS header, not the uTorrent header. If you need additional proof, uTorrent goes green immediately when I add the uTorrent rules to the WOS process, without me having to change anything else.