uTorrent problems

First, I know this question pops up regularly, but I did a search and none of the current threads are helping. :slight_smile:

I’m running Comodo Firewall Pro 3.0.21.329 on Vista Ultimate x64 and I’m desperately trying to get the green checkmark in uTorrent.

I have followed pandlouk’s tutorial to the letter, and still the port doesn’t show up as open in Port Checker. Random port at startup and uPnP are both disabled in uTorrent. When I disable Comodo, everything works fine, so I’m pretty confident the problem is with Comodo.

Here are the APPLICATION RULES I’m using for uTorrent:
Allow TCP or UDP In from Any to Any source 1025-65535 destination [uTorrent]
Allow TCP Out from Any to Any source 1024-65535 destination 1025-65535
Allow UDP Out from Any to Any source [uTorrent] destination 1024-65535
Ask TCP Out from Any to Any source 1025-65535 destination 80
Block and Log IP In/Out from Any to Any protocol ANY

I also added the following GLOBAL RULE
Allow TCP/UDP In from Any to Any source Any destination [uTorrent]

[uTorrent] is a port set containing the port uTorrent uses.

I cannot for the life of me figure out why the connection won’t go through. In Comodo v2 I used to check the log file to see which ports were getting blocked but now the log file is empty so there’s no way I can trace the problem. What’s up with that?

Read here.

https://forums.comodo.com/frequently_asked_questions_faq_for_comodo_firewall/tutorial_for_utorrent_with_comodo_firewall_3-t15677.0.html

As I said, I followed these instructions TO THE LETTER. Unless there’s another hint in that thread that I’ve overlooked, but in that case I’m afraid you’ll have to be more specific…

Have you tried running the stealth port wizard and selecting the P2P option?

Yup, I did that. Tried both the P2P and the last option, neither works.

Are you sure your router is port forwarded correctly? Your also not suppose to randomize your ports. uTorrent only connects to 1 port for me. After I port forwarded my modem all I did was make uTorrent trusted and it works. If you run the stealth port wizard for P2P you should have a different global rule then you show. Try deleting your rule and run the wizard again. Try restarting your modem also.

You should have a global rule stating something like Echo ping request block.

I do have an Echo request block rule at the bottom.
I’m also sure the router is configured correctly since when I disable comodo uTorrent works fine.
I do not randomize ports, I have not enabled UPnP.

I tried deleting my global rule but this doesn’t make any difference. I also tried restarting the modem, no dice.

Also, something I haven’t mentioned:
At some point uTorrent and Comodo did work together without any problems. I don’t know when it stopped working (maybe an update somewhere along the way?) but now it most definitely doesn’t. I’ve tried reinstallng Comodo three times already but it hasn’t solved my problem.

Update!

I used the Stealth wizard to hide my ports from everything and everyone (third bullet) and now I’m finally getting entries in the log file. TCP and UDP In connections to my uTorrent port are getting blocked, which I guess makes sense considering what I made the Stealth Wizard do.

Only, and this is where I think the problem lies, the application is not listed as uTorrent but as “Windows Operating System” which Comodo tells me is a pseudo-application, whatever that means.

Any idea why it does this?

Try deleting your uTorrent rules. I dont have any uTorrent rules. All I did was port forward my router to 51326 and then launched uTorrent. I then closed out uTorrent and went into my firewall rules and made it trusted. Then I went into D+ and made it trusted. Launched uTorrent and started downloading something and I had a green check mark. I only have 1 global rule since my modem takes care of all my inbounds.

[attachment deleted by admin]

My other rules.

[attachment deleted by admin]

I got uTorrent working by uninstalling Comodo completely. Then I launched uTorrent and it still wasn’t green. So I port forwarded my modem. Restarted my modem and uTorrent was green. Ok now I know uTorrent works fine. Then I installed Comodo and made uTorrent trusted and it works. Still green.

Thanks for the screenshots and the advice. However, it’s still not working for me.

I think I’ve narrowed down the problem:

The problem is that essential uTorrent traffic is being seen as “Windows Operating System” traffic by Comodo. Setting WOS to trusted solves the problem right away, but since as far as I understand WOS could be just about any kind of traffic, this seems like a very dangerous thing to do.

Can anyone tell me why my legitimate uTorrent traffic is being seen as WOS traffic?

I was getting that before cause I was using the block all incoming connections global rule. Then I switched to the P2P rule. Still getting WOS when I started uTorrent. Then I unplugged my modem for 10 minutes and shutdowm my pc. Restarted my modem and made sure all lights were green then I started my pc. What port to have uTorrent set to?

It looks to me like your rules are okay, but (trying not to sound like a ■■■■ here) are you sure they’re in the correct order? Is that Global (allow on Utor-port In) rule at the top of your Global rules when you run Utorrent?

(Utorrent will appear as WOS often if the application Utorrent is closed, or if the connection attempts fall outside of the allocated rules in CFP3 for Utorrent)

Show us a screen shot of your global rules and other rules in the firewall.

Ok, here are some screenshots.

I should note that I’ve also tried with the “stealth all” global rules and without the custom uTorrent rule. Nothing works.

Like I said, trusting WOS allows me to use uTorrent with the green checkmark, blocking WOS altogether means I no longer get the checkmark and that I can no longer surf the net. Simply allowing WOS for the uTorrent port works for uTorrent, but not for regular browsing.

If it helps, when I’m blocking WOS my log file is full of the following blocked request for Windows Operating System:
-TCP In requests to my uTorrent port (a lot of them!)
-some IGMP coming from my router
-some UDP Outs going from me to my router on port 53
-some TCP Outs to dest. port 80.

[attachment deleted by admin]

A couple of things:

Your rules look good, but you may want to allow TCP out from any [instead of range] to 80 and UDP out from any [instead of range] to 53 - I’m personally not aware of a specific security risk with this (although loosening the reigns on any app is a potential risk) and doing so has significantly sped up my DL’s and lessened blocks.

By going to Misc. > Settings > Logging > Here you may create specific rules for your Block/Allow logs - ie; how large and where they go. This will help ya find your lost logs, you can also usually click “More” at the bottom of “Firewall Events” to view the most recent.

Also go to Firewall > Advanced > Attack Detection Settings > Miscellaneous > and uncheck “Do protocol analysis” and/or anything else checked in that section (at least while you’re torrenting).

For the heck of it keep your U port in the 10,000+ range (mine is 36896)

Because of the nature of these blocks you’re describing I suspect the problem is not with your Utorrent configuration but rather with a glitch in your CFP configuration elsewhere - which is difficult to diagnose from a distance (and with my rudimentary understanding of Vista + the problem at hand).

I know how frustrating this can be (believe me) and hope some of this helps you.

■■■■

Utorrent only needs 1 port. Not a range. The same port that you port frowarded your modem to. Why don’t you just erase your rules and make it trusted. Your modem is taking care of your inboubnds. uTorrent only connects to port 53867 for me.

You know, funny you should say that Vet - back when I ran ver2.4 I had it all passing through the one port. Now Utor (no matter how I set it) is calling out all over the place. If I restrict the traffic to the single port my speeds (if any) are abysmal, the tracker wont work, and I get a bajillion blocks on 53, 80, and in the 1000-1500 range.
I thought this was wacky until I saw folks were working up multiple rules for Utor, here and elsewhere - I’ve never bothered to even ask “why”?
If Utorrent only needs the single port - why the multiple rules ala pandlouk?

(PS; using a tweaked version of pandlouk’s rules I get premium speeds.)