uTorrent problem - simple explanation probable.

Hi,

Previously my PC was connected to my router with a wireless usb adapter. When my internet was increased
from 2Mbits to 8Mbits I could not take advantage of it because my usb port was too slow or the driver for
the speedtouch usb adapter, not sure which.

Anyway, put in a ethernet PCI card and wired up the PC to the router - speed now v good.

Since I wanted to keep the wireless adapter installed in case I needed it the ethernet card had to have
a different IP address from the wireless adapter.

When using the wireless connection I had a port forwarded in my router for uTorrent and told comodo it was
a trusted application. So when connected via the cable I forwarded the port with the new IP address and kept
the uTorrent settings in comodo the same.

It does not work however - not accepting incoming connections - no green tick.
Someone suggested to me that a firewall was “protecting” the Local Area Network connection and not the Wireless?

When I looked at My Network Zones the wireless connection was the only connecton there and there were
global rules set for it in Network Security Policy. Comodo had not prompted me to set up my new network when it
was first connected.

Having added the new IP address and subnet mask to My Network Zones and set global rules for it as per
the wireless connection (used stealth ports wizard) I thought it would have fixed my UTorrent problem but it hasn’t.

To recap - Wireless and wired connections, both forwarded for the uTorrent port in the router and same rules
set for each with comodo but only the wireless connection works with uTorrent. ???

There must be a simple explanation for this.
Any help greatly appreciated.
Cheers.
:slight_smile:

Tutoiral for utorrent

Josh

Hey Gordie,
Since we know your Global rules are ok, and your ports forwarded properly, perhaps your Application Rules for Utorrent are address specific (if I gather correctly, this is really the only variable to change) and should be looked at.
Make sure you have something like:
Allow TCP/UDP In from IP Any to IP Any from port Any to Utorrent port

and not:
Allow TCP/UDP In from IP Any to 192.168.xx.xx from port Any to Utorrent port

Sorry if I missed the mark here - good luck!

Are you using the P2P option in the stealth port wizard?

Hi,

Thanks for the replys.
Had a try at your suggestion first Comofo cos it was shorter and
I’m a bit lazy. No joy so went with the link from Josh and created
the 5 rules. When I started uTorrent there was no pop up asking
to treat this application as uTorrent and remember the answer.
A test on uTorrent showed the port was not open.

As a test I disabled the Local Area Connection and enabled the
wireless connection. When I started uTorrent I was asked to
treat the application as uTorrent and all worked well.

Back to the wired connection to see if it worked now but not.

Seems that things are working properly for the wireless connection
only. Strange that I was not asked which predefined firewall policy
I wanted to treat the application as but when wireless I was.

Also tried the P2P option in the stealth ports wizard.

Any ideas?

Ok, think I’m getting somewhere.

Set up my network from scratch.
Think I may have had it wrong to start.
Instead of two network names I now have just
the one with two IP addresses attributed to it
underneath. Set global rules for the new network
with stealth ports wizard.

Have the 5 rules in Application Rules and uTorrent.exe is
treated as the predefined policy called uTorrent which
was created.

Now when I open uTorrent comodo pops up with a window
telling me uTorrent wants to connect to the internet -
(http: port 80) which I allow and ask it to remember then
nothing - waiting for the window asking me to treat uTorrent
under the predefined policy but nowt ( scots for nothing :slight_smile: ).

Thing is after this I go back in to application rules and uTorrent.exe
is no longer treated under the predefined policy but is marked as
custom.

If I can get the 5 rules to stick I might be on a winner.
Aslo tried the P2P option in stealth ports wizard again but
with no joy.

Thanks for your time with this.

Gordie.

Just noticed something.

As well as the predefined policy always changing
from uTorrent(what I called the 5 rules) to custom,
a new rule keeps appearing above the 5 rules.
Must be this that is buggering things up:

Allow IP Out from IP Any to IP Any where protocol is Any

Keep deleting it and it keeps coming back - ■■■■. :-\

Any thoughts?

Gotta make sure you click “Apply” every time and on each page - easy to miss or forget.

Application Rules set up ok now. Was not selecting UTorrent from the
drop down list in the alert, sorry about that.

not yet got a proper connection with the ethernet card.
All ok when I switch to wireless.

Moved the IP address for the Ethernet up one in list in
My Network Places so it was above the wireless one but
to no avail.

Will forward the port again to see if that helps.

Any more ideas?

Uninstalled comodo and rebooted.
Checked uTorrent.
Worked with wireless connection but
not with the wired one.
Looks as if I’ll need to find a new forum.
Thanks for your time.
Gordie.
:slight_smile:

Seems I was forwarding the same port to two
IP addresses.
Big no no.

Can I use the same rules as for uTorrent with
Limewire, just changing the port?

Thanks again.

Limewire for me doesn’t need the same rules. Limewire allows for firewall access but dont use Limewire. Use Frostwire.Its Limewire Pro for free and better.All I did was make it trusted under the firewall and D+.

OK. Nice one.
Cheers.
;D