uTorrent/Open Port

Need some help getting a port open. After some testing I have found that uTorrent works fine(in terms of opening a port) if i disable comodo, so my router Linksys WRT54GL running DD-WRT firmware, isnt the problem. Never had a problem getting a port open before untill i followed this guide:

The problem stems from the stealth port setting. If I stealth my ports to everyone it says the ports closed. Then I found this:
Tried it, and go no fix.

So for testing sake I used Stealth Port on a Per Case basis, and the port opens right up. Id like to achieve the best security available, so is there really much difference between the two options?

Also in the utorrent guide:
It suggests not use Protocol analysis, but the Max Security guide does. Using it or not using it doesnt seem to affect my PC. With out going into all the technical details lets just say I have a Core i 860(custom built pc) with some nice hardware to back it up. So is it ok to leave this running with uTorrent or not?

You want to be very safe. Then run the Stealt Ports Wizard and set CIS to stealth to all.

Then show me a screenshot of your Global Rules.

Heres my global rules. When I checked them today uTorrent had some how moved to the bottom of the pile.

When the rule is under the basic block rule the uTorrent won’t be working. How is the uTorrent rule in Global Rules defined?

When your uTorrent rule in Global Rules is right then the port is open. If you want to define tight program rules for uTorrent you can follow: https://forums.comodo.com/empty-t15677.0.html .

Here is the global rule from the screen shot.

Action = Allow
Protocol = TCP or UDP
Direction = In/out
Description = Utorrent
Source Address = Any
Destination Address = Any
Source port = any
Destination port =utorrent port

Now as for following the guide, I did just that, but that alone didnt work so i added the rule above. Still no luck.

Note that I have both the utorrent global rule and the predefined firewall policy at the top of there respective lists.

Thanks for your help btw.

Try changing Direction to In.

Still didnt work. :frowning: BTW uTorrent itself has a green check like the port is open, uTorrent.com port checker says its closed. I tested canyouseeme.org to, and it cant see the port open either.

You will need an IN rule for you uTorrent port in both Global and Application rules.

uTorrent will need to be running when checking if the port is open, otherwise it will be reported as either closed or stealth.

Well obviously I have an in rule for each, and its not working, and yes utorrents is running. I have been port forwarding for years. This isnt anything new. Thats why I need help is I simply cant figure this out when stealthing my ports.

If your rules have been created correctly, enabling Stealth Ports and turning on Protocol Analysis will not affect the operation of uTorrent. I have both of those options enabled and with the following rules, uTorrent works correctly, as verified by the port test on the uTorrent site.

[attachment deleted by admin]

Im not sure where your getting all these rules from because there not in the first post of the utorrent set up tutorial. I’ll see if I cant mimick it on this end and see if that works.

Here what I had.

Im also confused why you have 2 global rules. Why not merge it in to one changing the first rule to TCP/UDP instead of having a separate rules for each?

EDIT: Thanks to both of you Im good to go. Part of the problem may have been the uTorrent App Rules, but when I checked my Global Rule, I either forgot to change the port or the port change on its own(believe it or not). So regardless, I like the way your rules were defined Quill, so I stole that :stuck_out_tongue:

The only thing I did different from you, Quill, was a single In/Out rule for TCP and UDP in Global rules. Is there a particular reason I need two rules when one get the job done? Seems like the same could be said for the App Rules to.

Thanks again!

Glad you managed to get things working :slight_smile:

The only reason I use separate rules is for troubleshooting purposes; it’s much easier to find problems when things are isolated. This, however, is just my preferred way of doing things and is unnecessary it the wider scheme of things.

Ok thank you for the info.

Since we can no longer select “any” protocol, only specific protocols, should I set up a block rule for every protocol when doing a network rule for utorrent.